POJ 2230 Watchcow

Posted 一蓑烟雨任生平

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2230 Watchcow相关的知识,希望对你有一定的参考价值。

                      Watchcow
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 8537   Accepted: 3715   Special Judge

Description

Bessie‘s been appointed the new watch-cow for the farm. Every night, it‘s her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she‘s done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she‘s seen everything she needs to see. But since she isn‘t, she wants to make sure she walks down each trail exactly twice. It‘s also important that her two trips along each trail be in opposite directions, so that she doesn‘t miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS: 

Bessie starts at 1 (barn), goes to 2, then 3, etc...

Source

题意:题目大意:给出n个field及m个连接field的边,然后要求遍历每条边仅且2次,求出一条路径来。
思路:题目保证一定有解,所以找一个欧拉回路即可,dfs。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 100010 
using namespace std;
int n,m,tot;
int vis[MAXN];
int to[MAXN],net[MAXN],head[MAXN];
void add(int u,int v){
    to[++tot]=v;net[tot]=head[u];head[u]=tot;
    to[++tot]=u;net[tot]=head[v];head[v]=tot;
}
void dfs(int now){
    for(int i=head[now];i;i=net[i])
        if(!vis[i]){
            vis[i]=1;
            dfs(to[i]);
        }
    cout<<now<<endl;
}
int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++){
        int x,y;
        scanf("%d%d",&x,&y);
        add(x,y);
    }
    dfs(1);
}

 

以上是关于POJ 2230 Watchcow的主要内容,如果未能解决你的问题,请参考以下文章

[2016-01-27][POJ][2230][Watchcow]

POJ 2230 Watchcow

POJ 2230 Watchcow

poj2230 Watchcow(欧拉回路)

POJ2230 Watchcow - 欧拉回路

[POJ | Nowcoder] Watchcow | 欧拉回路 点路径输出