UVA_1434_YAPTCHA

Posted 会飞的雅蠛蝶

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA_1434_YAPTCHA相关的知识,希望对你有一定的参考价值。

The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.


However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute
技术分享图片

where [x] denotes the largest integer not greater than x.

InputThe first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).OutputFor each n given in the input output the value of Sn.Sample Input

13
1
2
3
4
5
6
7
8
9
10
100
1000
10000

Sample Output

0
1
1
2
2
2
2
3
3
4
28
207
1609

被减数P 一定大于减数Q,并且P,Q相差不大,转化成了当切仅当P为整数的时候。
威尔逊定理:当且仅当p为素数时:( p -1 )! ≡ -1 ( mod p )
通过威尔逊定理,(P-1)!+1≡ 0 ( mod p ),本题就转化成求3*k+7是否为素数的问题。
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
#define mod 1000000
#define N 3000005
typedef long long LL;
int prime[N];
bool vis[N];
int val[N];
int pn=0;
int ans[N];
int main ()
{
    for (int i = 2; i < N; i++) {
        if (vis[i]) continue;
        val[i]=1;
        prime[pn++] = i;
        for (int j = i; j < N; j += i)
            vis[j] = 1;
    }
    for(int i=1;i<=1000000;i++)
    {
        ans[i+1]=ans[i]+val[3*i+10];
    }
    int t;
    while(~scanf("%d",&t))
    {
        int n;
        while(t--)
        {
            scanf("%d",&n);
            cout<<ans[n]<<endl;
        }
    }

}

  












以上是关于UVA_1434_YAPTCHA的主要内容,如果未能解决你的问题,请参考以下文章

UVA 1434 - YAPTCHA(数论)

[UVA1434] YAPTCHA(数论,威尔逊定理)

具有两种不同输入样本大小的 Keras 多任务学习

[AndroidStudio]_[初级]_[配置自动完成的代码片段]

VSCode 配置 用户自定义代码片段 自定义自动代码补充

[AndroidStudio]_[初级]_[配置自动完成的代码片段]