洛谷P3070 [USACO13JAN]岛游记Island Travels

Posted Soda

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了洛谷P3070 [USACO13JAN]岛游记Island Travels相关的知识,希望对你有一定的参考价值。

P3070 [USACO13JAN]岛游记Island Travels

题目描述

Farmer John has taken the cows to a vacation out on the ocean! The cows are living on N (1 <= N <= 15) islands, which are located on an R x C grid (1 <= R, C <= 50). An island is a maximal connected group of squares on the grid that are marked as ‘X‘, where two ‘X‘s are connected if they share a side. (Thus, two ‘X‘s sharing a corner are not necessarily connected.)

Bessie, however, is arriving late, so she is coming in with FJ by helicopter. Thus, she can first land on any of the islands she chooses. She wants to visit all the cows at least once, so she will travel between islands until she has visited all N of the islands at least once.

FJ‘s helicopter doesn‘t have much fuel left, so he doesn‘t want to use it until the cows decide to go home. Fortunately, some of the squares in the grid are shallow water, which is denoted by ‘S‘. Bessie can swim through these squares in the four cardinal directions (north, east, south, west) in order to travel between the islands. She can also travel (in the four cardinal directions) between an island and shallow water, and vice versa.

Find the minimum distance Bessie will have to swim in order to visit all of the islands. (The distance Bessie will have to swim is the number of distinct times she is on a square marked ‘S‘.) After looking at a map of the area, Bessie knows this will be possible.

给你一张r*c的地图,有’S’,’X’,’.’三种地形,所有判定相邻与行走都是四连通的。我们设’X’为陆地,一个’X’连通块为一个岛屿,’S’为浅水,’.’为深水。刚开始你可以降落在任一一块陆地上,在陆地上可以行走,在浅水里可以游泳。并且陆地和浅水之间可以相互通行。但无论如何都不能走到深水。你现在要求通过行走和游泳使得你把所有的岛屿都经过一边。Q:你最少要经过几个浅水区?保证有解。

输入输出格式

输入格式:

 

  • Line 1: Two space-separated integers: R and C.

  • Lines 2..R+1: Line i+1 contains C characters giving row i of the grid. Deep water squares are marked as ‘.‘, island squares are marked as ‘X‘, and shallow water squares are marked as ‘S‘.

 

输出格式:

 

  • Line 1: A single integer representing the minimum distance Bessie has to swim to visit all islands.

 

输入输出样例

输入样例#1:
5 4 
XX.S 
.S.. 
SXSS 
S.SX 
..SX 
输出样例#1:
3 

说明

There are three islands with shallow water paths connecting some of them.

Bessie can travel from the island in the top left to the one in the middle, swimming 1 unit, and then travel from the middle island to the one in the bottom right, swimming 2 units, for a total of 3 units.

技术分享
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int n,m,ans=0x7fffffff,tot;
int e[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
bool vis[60][60];
char map[60][60];
void dfs(int x,int y,int cnt,int sum){
    if(sum>=ans)return;
    if(cnt==tot){
        ans=min(ans,sum);
        return;
    }
    for(int i=0;i<4;i++){
        int xx=x+e[i][0],yy=y+e[i][1];
        if(xx<=n&&xx>=1&&yy<=m&&yy>=1&&map[xx][yy]!=.&&!vis[xx][yy]){
            vis[xx][yy]=1;
            dfs(xx,yy,cnt+(map[xx][yy]==X),sum+(map[xx][yy]==S));
            vis[xx][yy]=0;
        }
    }
}
int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)scanf("%s",map[i]+1);
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
            if(map[i][j]==X)tot++;
    for(int i=1;i<=n;i++){
        for(int j=1;j<=m;j++){
            if(map[i][j]==X){
                memset(vis,0,sizeof(vis));
                vis[i][j]=1;
                dfs(i,j,1,0);
            }
        }
    }
    cout<<ans;
}
36分 暴力

 

以上是关于洛谷P3070 [USACO13JAN]岛游记Island Travels的主要内容,如果未能解决你的问题,请参考以下文章

洛谷 P2205 [USACO13JAN]画栅栏Painting the Fence

洛谷P2202 [USACO13JAN]方块重叠Square Overlap

洛谷P2205 [USACO13JAN]画栅栏Painting the Fence

洛谷 P2205 [USACO13JAN]画栅栏Painting the Fence

洛谷P3043 [USACO12JAN]牛联盟Bovine Alliance

洛谷P3116 [USACO15JAN]约会时间Meeting Time