HDU 1517 A Multiplication Game 博弈

Posted Hyouka

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1517 A Multiplication Game 博弈相关的知识,希望对你有一定的参考价值。

A Multiplication Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6202    Accepted Submission(s): 3532


Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

 

Input
Each line of input contains one integer number n.
 

 

Output
For each line of input output one line either 

Stan wins. 

or 

Ollie wins.

assuming that both of them play perfectly.
 

 

Sample Input
162 17 34012226
 

 

Sample Output
Stan wins. Ollie wins. Stan wins.

 

手动找规律
分列出先手选了2-9之后的情况
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <vector>
#include <iomanip>
#include <math.h>
#include <map>
#include <time.h>
using namespace std;
#define FIN     freopen("input.txt","r",stdin);
#define FOUT    freopen("output.txt","w",stdout);
#define INF     0x3f3f3f3f
#define INFLL   0x3f3f3f3f3f3f3f
#define lson    l,m,rt<<1
#define rson    m+1,r,rt<<1|1
typedef long long LL;
typedef pair<int, int> PII;
using namespace std;

int main() {
    //FIN
    double n;
    while(cin >> n) {
        while(n > 18) n /= 18;
        if(n <= 9) puts("Stan wins.");
        else puts("Ollie wins.");

    }

    return 0;
}

  

以上是关于HDU 1517 A Multiplication Game 博弈的主要内容,如果未能解决你的问题,请参考以下文章

hdu 1517 A Multiplication Game(必胜态,必败态)

HDU1517A Multiplication Game

Hdoj 1517.A Multiplication Game 题解

HDU 1082 Matrix Chain Multiplication

HDU 4920: Matrix multiplication

hdu1082 Matrix Chain Multiplication