bzoj1651: [Usaco2006 Feb]Stall Reservations 专用牛棚
Posted 安
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了bzoj1651: [Usaco2006 Feb]Stall Reservations 专用牛棚相关的知识,希望对你有一定的参考价值。
1651: [Usaco2006 Feb]Stall Reservations 专用牛棚
Time Limit: 10 Sec Memory Limit: 64 MBSubmit: 942 Solved: 544
[Submit][Status][Discuss]
Description
Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. Help FJ by determining: * The minimum number of stalls required in the barn so that each cow can have her private milking period * An assignment of cows to these stalls over time
有N头牛,每头牛有个喝水时间,这段时间它将专用一个Stall 现在给出每头牛的喝水时间段,问至少要多少个Stall才能满足它们的要求
Input
* Line 1: A single integer, N
* Lines 2..N+1: Line i+1 describes cow i‘s milking interval with two space-separated integers.
Output
* Line 1: The minimum number of stalls the barn must have.
* Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.
Sample Input
1 10
2 4
3 6
5 8
4 7
Sample Output
OUTPUT DETAILS:
Here‘s a graphical schedule for this output:
Time 1 2 3 4 5 6 7 8 9 10
Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>
Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..
Stall 3 .. .. c3>>>>>>>>> .. .. .. ..
Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.
HINT
不妨试下这个数据,对于按结束点SORT,再GREEDY的做法 1 3 5 7 6 9 10 11 8 12 4 13 正确的输出应该是3
/*
红果果的差分题目
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#define N 500001
using namespace std;
int a[N<<2],l,r,n,m,L,R,ans;
int main()
{
scanf("%d",&n);L=1,R=1000000;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&l,&r);
a[l]++;a[r+1]--;
}
int tot=0;
for(int i=L;i<=R;i++)
{
tot+=a[i];
ans=max(ans,tot);
}
printf("%d\n",ans);
return 0;
}
以上是关于bzoj1651: [Usaco2006 Feb]Stall Reservations 专用牛棚的主要内容,如果未能解决你的问题,请参考以下文章
[BZOJ1651][Usaco2006 Feb]Stall Reservations 专用牛棚
bzoj1651: [Usaco2006 Feb]Stall Reservations 专用牛棚
bzoj1651[Usaco2006 Feb]Stall Reservations 专用牛棚*
差分BZOJ 1651 [Usaco2006 Feb]Stall Reservations 专用牛棚
bzoj 1651: [Usaco2006 Feb]Stall Reservations 专用牛棚贪心+堆||差分
BZOJ 1651 [Usaco2006 Feb]Stall Reservations 专用牛棚:优先队列线段最大重叠层数