poj 1125 (floyed 最短路径)

Posted brucemengbm

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 1125 (floyed 最短路径)相关的知识,希望对你有一定的参考价值。

Stockbroker Grapevine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 26395   Accepted: 14558

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a ‘1‘ means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source

Southern African 2001

#include<iostream>
using namespace std;
int main(){
    int G[105][105];
    int n,m;
    while(cin>>n&&n){
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(i==j)
                    G[i][j]=0;
                else
                    G[i][j]=999999;
        for(int i=1;i<=n;i++){
           cin>>m;
           for(int j=1;j<=m;j++){
               int v,t;    cin>>v>>t;
               G[i][v]=t;
           }
        }
        for(int k=1;k<=n;k++)
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            //    for(int k=1;k<=n;k++)     k要放在前面,放这里会wrong answer 
                G[i][j]= G[i][j] > G[i][k]+G[k][j] ? G[i][k]+G[k][j] : G[i][j];

        int v,t;
        t=999999;
        v=0;
        for(int i=1;i<=n;i++){
            int max; max=0;
            for(int j=1;j<=n;j++){
                if(G[i][j]>max)
                    max=G[i][j];
            }
            if(max>=999999)
                continue;
            if(t>max){
                t=max;
                v=i;
            }
        }
        if(v==0)
            cout<<"disjoint"<<endl;
        else
            cout<<v<<' '<<t<<endl;
    }
    return 0;
}


以上是关于poj 1125 (floyed 最短路径)的主要内容,如果未能解决你的问题,请参考以下文章

最短路径Floyed算法

图论 最短路径算法 1.Floyed-Warshall算法

数据结构与算法图最短路径算法 ( Floyed 算法 | 图最短路径算法使用场景 | 求解图中任意两个点之间的最短路径 | 邻接矩阵存储图数据 | 弗洛伊德算法总结 )

最短路径——Floyed

图论最短路径Floyed算法和Dijkstra算法

poj1125 基础最短路