UVa 825 Walking on the Safe Side(DP)

Posted jhcelue

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVa 825 Walking on the Safe Side(DP)相关的知识,希望对你有一定的参考价值。

Walking on the Safe Side 

Square City is a very easy place for people to walk around. The two-way streets run North-South or East-West dividing the city into regular blocks. Most street intersections are safe for pedestrians to cross. In some of them, however, crossing is not safe and pedestrians are forced to use the available underground passages. Such intersections are avoided by walkers. The entry to the city park is on the North-West corner of town, whereas the railway station is on the South-East corner.


Suppose you want to go from the park to the railway station, and do not want to walk more than the required number of blocks. You also want to make your way avoiding the underground passages, that would introduce extra delay. Your task is to determine the number of different paths that you can follow from the park to the station, satisfying both requirements.

The example in the picture illustrates a city with 4 E-W streets and 5 N-S streets. Three intersections are marked as unsafe. The path from the park to the station is 3 + 4 = 7 blocks long and there are 4 such paths that avoid the underground passages.

技术分享

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.


The first line of the input contains the number of East-West streets W and the number of North-South streetsN. Each one of the following W lines starts with the number of an East-West street, followed by zero or more numbers of the North-South crossings which are unsafe. Streets are numbered from 1.

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.


The number of different minimal paths from the park to the station avoiding underground passages.

Sample Input 

1

4 5
1
2 2
3 3 5
4

Sample Output 

4


本题算法上没难度  起点方法设为1  每一个点的方法等于其上方的点的方法数加上其左边的点的方法数    输入实在搞不懂。

凝视掉的部分求指错!!


#include<cstdio>
#include<cstring>
#include<cctype>
using namespace std;
const int N = 1005;
int d[N][N], w, n;
char s[N];  bool g[N][N];
int main()
{
    int  unsafe, t, row;
    scanf("%d", &t);
    while (t--)
    {
        gets(s);
        memset(g, 1, sizeof(g));
        scanf("%d %d\n", &w, &n);
        for(int i = 1; i <= w; i++)
        {
//            scanf("%d", &row);
//            while(getchar()==' ')
//            {
//                scanf("%d", &unsafe);
//                g[row][unsafe] = 0;
//            }

            gets(s);
            for(int j = 1, unsafe = 0; j <= strlen(s); j++)
            {
                if(isdigit(s[j]))
                    unsafe = unsafe * 10 + s[j] - '0';
                else
                {
                    g[row][unsafe] = 0;
                    unsafe = 0;
                }
            }
        }

        memset(d, 0, sizeof(d));
        d[1][0] = 1;
        for(int i = 1; i <= w; ++i)
            for(int j = 1; j <= n; ++j)
            {
                if(g[i][j])
                    d[i][j] = d[i - 1][j] + d[i][j - 1];
            }

        printf("%d\n", d[w][n]);
        if(t)
            printf("\n");
    }
    return 0;
}








以上是关于UVa 825 Walking on the Safe Side(DP)的主要内容,如果未能解决你的问题,请参考以下文章

uva 122 trees on the level——yhx

UVA-122(Trees on the level)

Uva 1614 - Hell on the Markets

UVa1614 Hell on the Markets (贪心,结论)

UVa 825简单dp,递推

Uva 122 Trees on the level