POJ 3450--Corporate IdentityKMP && 枚举

Posted jzssuanfa

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 3450--Corporate IdentityKMP && 枚举相关的知识,希望对你有一定的参考价值。

Corporate Identity
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 5696   Accepted: 2075

Description

Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones.

After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still be used while showing the new identity.

Your task is to find such a sequence.

Input

The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters.

After the last trademark, the next task begins. The last task is followed by a line containing zero.

Output

For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty string, output the words “IDENTITY LOST” instead.

Sample Input

3
aabbaabb
abbababb
bbbbbabb
2
xyz
abc
0

Sample Output

abb
IDENTITY LOST
思路:枚举一个串的所有子串。推断该子串有没有在其他串中出现。若在其他串中所有出现 则更新子串,否则枚举下一个子串。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char str[4010][210];
int next[210];

void getnext(char *s1){
    int j = 0, k = -1;
    int len = strlen(s1);
    next[0] = -1;
    while(j < len){
        if(k == -1 || s1[j] == s1[k]){
            ++j;
            ++k;
            next[j] = k;
        }
        else k = next[k];
    }
    return ;
}

bool kmp(char *s1, char *s2){
    int len1 = strlen(s2);
    int len2 = strlen(s1);
    getnext(s1);
    int i = 0, j = 0;
    while(i < len1){
        if(j == -1 || s1[j] == s2[i]){
            ++i;
            ++j;
        }
        else j=next[j];
        if(j == len2)
            return true;
    }
    return false;
}

int main(){
    int n;
    while(scanf("%d", &n), n){
        for(int i = 0 ; i < n; ++i)
            scanf("%s", str[i]);
        char temp[220];
        char sum[220] = "";
        int len = strlen(str[0]);
        for(int i = 0; i < len; ++i){
            int ans  = 0;
            for(int j = i; j < len; ++j){
                temp[ans++] = str[0][j];
                temp[ans] = '\0';
                int flag = 1;
                for(int k = 0 ; k < n; ++k){
                    if(!kmp(temp, str[k])){
                        flag = 0;
                        break;
                    }
                }
                if(flag){
                    if(strlen(temp) > strlen(sum))
                        memcpy(sum, temp, sizeof(temp));
                    else if(strlen(temp) == strlen(sum) && strcmp(temp, sum) < 0)
                        memcpy(sum, temp, sizeof(temp));
                }
            }
        }
        if(strlen(sum) == 0)
            printf("IDENTITY LOST\n");
        else
            printf("%s\n", sum);
    }
    return 0;
}


以上是关于POJ 3450--Corporate IdentityKMP &amp;&amp; 枚举的主要内容,如果未能解决你的问题,请参考以下文章

POJ 3450 Corporate Identity(KMP)

POJ3450 Corporate Identity

POJ3080 POJ3450Corporate Identity(广义后缀自动机||后缀数组||KMP)

POJ 3450--Corporate IdentityKMP &amp;&amp; 枚举

期待 IDENT,找到 ':'

ident_current 显示错误的最后插入 id