codevs1230 元素查找

Posted Code_Together

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了codevs1230 元素查找相关的知识,希望对你有一定的参考价值。

题目描述 Description

给出n个正整数,然后有m个询问,每个询问一个整数,询问该整数是否在n个正整数中出现过。

输入描述 Input Description

第一行两个整数 n 和m。

第二行n个正整数(1<=n<= 100000)

第三行m个整数(1<=m<=100000)

输出描述 Output Description

一共m行,若出现则输出YES,否则输出NO

样例输入 Sample Input

4 2

2 1 3 4

1 9

样例输出 Sample Output

YES

NO

数据范围及提示 Data Size & Hint

所有数据都不超过10^8

 

//钻石的题目???

 

#include<bits/stdc++.h>
using namespace std;
int n,m;
bool f[100010];

int main(){
	scanf("%d%d",&n,&m);
	while(n--){
		int x;
		scanf("%d",&x);
		f[x]=true;
	}
	while(m--){
		int x;
		scanf("%d",&x);
		if(f[x])printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}


以上是关于codevs1230 元素查找的主要内容,如果未能解决你的问题,请参考以下文章

[Codevs 1230]元素查找(手写哈希表)

codevs1230 元素查找

1230 元素查找

1230 元素查找

STL万岁。。 CODEVS 1230。

codevs哈希水题