Hdu 1702 ACboy needs your help again!

Posted 寂地沉

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Hdu 1702 ACboy needs your help again!相关的知识,希望对你有一定的参考价值。

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7824    Accepted Submission(s): 3945

Problem Description

ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can‘t image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster‘s labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can‘t solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem‘s first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

 

 

Input

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

 

 

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don‘t have any integer.

 

 

Sample Input

4

4 FIFO

IN 1

IN 2

OUT

OUT

4 FILO

IN 1

IN 2

OUT

OUT

5 FIFO

IN 1

IN 2

OUT

OUT

OUT

5 FILO

IN 1

IN 2

OUT

IN 3

OUT

 

 

Sample Output

1

2

2

1

1

2

None

2

3

#include<stdio.h>
#include<stack>
#include<queue>
#include<string.h>
using namespace std;
int main()
{
 int N,i;
scanf("%d",&N);
while(N--)
 {
  int n,k;
  char a[5],s[4];
 scanf("%d %s",&n,a);
  if(strcmp(a,"FIFO")==0)
  {
    queue<int> qu;
   for(k=0;k<n;k++)
   { 
    scanf("%s",s);
   if(strcmp(s,"IN")==0)
   {
    int u;
    scanf("%d",&u);
    qu.push(u);
   } 
   else
   {
    if(qu.empty())
    printf("None\n");
    else
    {
     int u=qu.front();
      printf("%d\n",u);
     qu.pop();
    }
   }
   }
  }
 else
 { stack<int> qu;
      for(k=0;k<n;k++)
  {  
      scanf("%s",s);
  if(strcmp(s,"IN")==0)
  {
   int u;
   scanf("%d",&u);
   qu.push(u);
  } 
  else
  {
   if(qu.empty())
    printf("None\n");
   else
   {
   int u=qu.top();
   printf("%d\n",u);
        qu.pop();
   }
  }
   }
 }
}
 return 0;
}

  

以上是关于Hdu 1702 ACboy needs your help again!的主要内容,如果未能解决你的问题,请参考以下文章

Hdu 1702 ACboy needs your help again!

hdu1702 ACboy needs your help again!

A - ACboy needs your help again! (HDU - 1702)

HDUOJ P1702 ACboy needs your help again!

hdu1712 ACboy needs your help

hdu 1712 ACboy needs your help(分组背包入门)