HDU 5347(MZL's chemistry-打表)

Posted lytwajue

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 5347(MZL's chemistry-打表)相关的知识,希望对你有一定的参考价值。

MZL‘s chemistry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 629    Accepted Submission(s): 449


Problem Description
MZL define as the first ionization energy of the chemical element

Now he get two chemical elements ,given as their atomic number,he wants to compare and

It is guaranteed that atomic numbers belongs to the given set:

It is guaranteed the two atomic numbers is either in the same period or in the same group

It is guaranteed that
 

Input
There are several test cases

For each test case,there are two numbers ,means the atomic numbers of the two element
 

Output
For each test case,if ,print "FIRST BIGGER",else print"SECOND BIGGER"
 

Sample Input
1 2 5 3
 

Sample Output
SECOND BIGGER FIRST BIGGER
 

Author
SXYZ
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:  5416 5415 5414 5413 5412 
 



打表




#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cctype>
#include<ctime>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define RepD(i,n) for(int i=n;i>=0;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
#define Forpiter(x) for(int &p=iter[x];p;p=next[p])  
#define Lson (x<<1)
#define Rson ((x<<1)+1)
#define MEM(a) memset(a,0,sizeof(a));
#define MEMI(a) memset(a,127,sizeof(a));
#define MEMi(a) memset(a,128,sizeof(a));
#define INF (2139062143)
#define F (100000007)
#define MAXN (1000000+10)
typedef long long ll;
ll mul(ll a,ll b){return (a*b)%F;}
ll add(ll a,ll b){return (a+b)%F;}
ll sub(ll a,ll b){return (a-b+llabs(a-b)/F*F+F)%F;}
void upd(ll &a,ll b){a=(a%F+b%F)%F;}
int a[24]={1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,35,36,53,54,85,86} ; 
double f[24]={1312.0,2372.3,520.2,899.5,800.6,1086.5,1402.3,1313.9,1681,2080.7,495.8,737.7,577.5,786.5,1011.8,999.6,1251.2,1520.6,1139.9,1350.8,1008.4,1170.4,890,1037};
double h[1000];
int main()
{
//	freopen("E.in","r",stdin);
	
	Rep(i,24) h[a[i]]=f[i];
	
	int u,v;
	while (cin>>u>>v)
	{
		if (h[u]<h[v]) puts("SECOND BIGGER");
		else puts("FIRST BIGGER");
	}
	
	
	return 0;
}





以上是关于HDU 5347(MZL&#39;s chemistry-打表)的主要内容,如果未能解决你的问题,请参考以下文章

hdu 5348 MZL&#39;s endless loop

HDU 5343 MZL's Circle Zhou 后缀自动机+DP

hdu 4274 Spy&#39;s Work(水题)

hdu5371 Hotaru&#39;s problem

HDU1161 Eddy&#39;s mistakes

hdu 3177 Crixalis&#39;s Equipment