POJ2481:Cows(树状数组)

Posted mthoutai

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ2481:Cows(树状数组)相关的知识,希望对你有一定的参考价值。

Description

Farmer John‘s cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John‘s N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

But some cows are strong and some are weak. Given two cows: cow i and cow j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow i is stronger than cow j

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases. 
For each test case, the first line is an integer N (1 <= N <= 10 5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10 5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge. 

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow i

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

Hint

Huge input and output,scanf and printf is recommended.

Source



题意:
对于每头牛,吃草的区间在li,ri之间。问在n头牛中,对于第i头牛而言,有几头牛的区间大于这头牛

思路:
能够使用树状数组,先排好序。再统计当中一个就可以

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <list>
#include <algorithm>
#include <climits>
using namespace std;

#define lson 2*i
#define rson 2*i+1
#define LS l,mid,lson
#define RS mid+1,r,rson
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define gcd(a,b) __gcd(a,b)
#define LL long long
#define N 200005
#define INF 0x3f3f3f3f
#define EXP 1e-8
#define lowbit(x) (x&-x)
const int mod = 1e9+7;

struct node
{
    int l,r,id;
} a[N];
int n,maxn,c[N];

int cmp(node a,node b)
{
    if(a.r!=b.r)
        return a.r>b.r;
    return a.l<b.l;
}

int sum(int x)
{
    int ret = 0;
    while(x>0)
    {
        ret+=c[x];
        x-=lowbit(x);
    }
    return ret;
}

void add(int x,int d)
{
    while(x<=maxn+1)
    {
        c[x]+=d;
        x+=lowbit(x);
    }
}

int ans[N];
int main()
{
    int i,j,k,l,r;
    while(~scanf("%d",&n),n)
    {
        MEM(ans,0);
        MEM(c,0);
        maxn = -1;
        for(i = 1; i<=n; i++)
        {
            scanf("%d%d",&a[i].l,&a[i].r);
            a[i].id = i;
            maxn = max(maxn,a[i].r);
        }
        sort(a+1,a+1+n,cmp);
        for(i = 1; i<=n; i++)
        {
            if(a[i].l == a[i-1].l && a[i].r == a[i-1].r)
            {
                ans[a[i].id] = ans[a[i-1].id];
            }
            else
            {
                ans[a[i].id] = sum(a[i].l+1);
            }
            add(a[i].l+1,1);
        }
        printf("%d",ans[1]);
        for(i = 2; i<=n; i++)
            printf(" %d",ans[i]);
        printf("\n");
    }

    return 0;
}


以上是关于POJ2481:Cows(树状数组)的主要内容,如果未能解决你的问题,请参考以下文章

POJ 2481 Cows树状数组

POJ - 2481 - Cows

poj 2481 cows

poj 2481 Cows

POJ 2481 Cows

POJ2481 Cows