hdu2099 整除的位数(暴力)

Posted lxjshuju

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu2099 整除的位数(暴力)相关的知识,希望对你有一定的参考价值。

一个整数,仅仅知道前几位。不知道末二位,被还有一个整数除尽了,那么该数的末二位该是什么呢?
 
Input
输入数据有若干组,每组数据包括二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束。
 

Output
相应每组数据,将满足条件的全部尾数在一行内输出,格式见样本输出。

同组数据的输出,其每一个尾数之间空一格,行末没有空格。

 

Sample Input
200 40 1992 95 0 0
 

Sample Output
00 40 80 15 题目分析; 直接暴力就可以。 AC代码:
/**
 *直接暴力模拟
 */
#include<iostream>
#include<cstdio>
#include<map>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
#include<cstdlib>
#include<cctype>
#include<cstring>
#include<cmath>
using namespace std;
int main()
{
    int a,b,s;
    while(cin>>a>>b&&(a+b>0)){
        int ok=0;//控制输出空格
        for(int i=0;i<=9;i++){
            for(int j=0;j<=9;j++){
                s=a*100+i*10+j;
                if(s%b==0){
                    if(!ok){
                        cout<<i<<j;
                        ok=1;
                    }
                    else cout<<" "<<i<<j;
                }
            }
        }
        cout<<endl;
    }
    return 0;
}


以上是关于hdu2099 整除的位数(暴力)的主要内容,如果未能解决你的问题,请参考以下文章

Poj2099 整除的尾数

HDU 6274 Master of Sequence (暴力+下整除)

HDU 5701 中位数计数 暴力

HDU 5701 中位数计数( 2016"百度之星" - 初赛(Astar Round2B) 思维 + 暴力)

hdu2099

HDU 3652 区间有13并且这样整除13 的数量(数位DP)