poj 3616 Milking Time

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 3616 Milking Time相关的知识,希望对你有一定的参考价值。

Language:
Milking Time
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9534   Accepted: 3958

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ‘s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43
题目很简单,类比最长上升子序列做就行
#include <iostream>
#include <cmath>
#include <cstring>
#include <iomanip>
#include <cstdio>
#include <algorithm>
using namespace std;
struct Node
{
    int b_time;
    int e_time;
    int milk;
}a[1010];
int dp[1010];
bool cmp(Node a,Node b)
{
    return a.e_time<b.e_time;
}
int main()
{
    int n,k,res;
    cin>>n>>k>>res;
    for(int i=0;i<k;i++)
        cin>>a[i].b_time>>a[i].e_time>>a[i].milk;
    sort(a,a+k,cmp);
    for(int i=0;i<k;i++)
    {
        dp[i]=a[i].milk;
        for(int j=0;j<i;j++)
            if(a[j].e_time+res<=a[i].b_time&&dp[j]+a[i].milk>dp[i])
            dp[i]=(dp[j]+a[i].milk);
    }
    cout<<*max_element(dp,dp+k)<<endl;
}

  

以上是关于poj 3616 Milking Time的主要内容,如果未能解决你的问题,请参考以下文章

Milking Time POJ - 3616

poj 3616 Milking Time

POJ3616 Milking Time —— DP

POJ_3616_Milking Time

POJ 3616 Milking Time(加掩饰的LIS)

poj 3616 Milking Time dp