HDU 5056 Boring count(数学)

Posted slgkaifa

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 5056 Boring count(数学)相关的知识,希望对你有一定的参考价值。

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5056


Problem Description
You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
 
Input
In the first line there is an integer T , indicates the number of test cases.
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.

[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
 
Output
For each case, output a line contains the answer.
 
Sample Input
3 abc 1 abcabc 1 abcabc 2
 
Sample Output
6 15 21
 
Source


官方题解:
技术分享

代码例如以下:
#include <cstdio>
#include <cstring>
const int maxn = 100017;
int main()
{
    int t;
    char str[maxn];
    int st[27];
    int k;
    scanf("%d",&t);
    while(t--)
    {
        memset(st,0,sizeof(st));
        scanf("%s",str);
        scanf("%d",&k);
        __int64 ans = 0;
        int len = strlen(str);
        int startpos = 0;
        for(int i = 0; i < len; i++)
        {
            int tt = str[i] -‘a‘;
            st[tt]++;
            if(st[tt] > k)
            {
                while(str[startpos]!=str[i])
                {
                    st[str[startpos]-‘a‘]--;
                    startpos++;
                }
                st[str[startpos]-‘a‘]--;
                startpos++;
            }
            ans+=i-startpos+1;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

















以上是关于HDU 5056 Boring count(数学)的主要内容,如果未能解决你的问题,请参考以下文章

[HDU3518]Boring counting

[HDU]3518——Boring counting

hdu3518 Boring counting

HDU3518 Boring counting

hdu Boring count(BestCode round #11)

hdu3518 Boring Counting[后缀排序]