1005 Number Sequence
Posted
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1005 Number Sequence相关的知识,希望对你有一定的参考价值。
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
#include<iostream>
using namespace std;
#define N 10000
int main()
{
int A,B,n;
cin>>A>>B>>n;
n=n%49;
while(!(A==0&&B==0&&n==0))
{
long long int a[N];
a[1]=1;
a[2]=1;
if(n==1||n==2)
{
cout<<1<<endl;
}
else
{
for(int i=3;i<=n;i++)
{
a[i]=(A*a[i-1]+B*a[i-2])%7;
}
cout<<a[n]<<endl;
}
cin>>A>>B>>n;
n=n%49;
}
return 0;
}
由于f(n)是由前两个数字组合产生,那么只要有两个数字组合相同的情况发生就一定一会产生循环!
两个数字的组合的最大可能值为7x7=49,因此只要在调用迭代方法中限制n的在0~48就可以了
以上是关于1005 Number Sequence的主要内容,如果未能解决你的问题,请参考以下文章