hdu 5078

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 5078相关的知识,希望对你有一定的参考价值。

Osu!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 58    Accepted Submission(s): 41
Special Judge


Problem Description
Osu! is a very popular music game. Basically, it is a game about clicking. Some points will appear on the screen at some time, and you have to click them at a correct time.

技术分享

Now, you want to write an algorithm to estimate how diffecult a game is.

To simplify the things, in a game consisting of N points, point i will occur at time ti at place (xi, yi), and you should click it exactly at ti at (xi, yi). That means you should move your cursor from point i to point i+1. This movement is called a jump, and the difficulty of a jump is just the distance between point i and point i+1 divided by the time between ti and ti+1. And the difficulty of a game is simply the difficulty of the most difficult jump in the game.

Now, given a description of a game, please calculate its difficulty.
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 1000) denoting the number of the points in the game.  Then N lines follow, the i-th line consisting of 3 space-separated integers, ti(0 ≤ ti < ti+1 ≤ 106), xi, and yi (0 ≤ xi, yi ≤ 106) as mentioned above.
 

Output
For each test case, output the answer in one line.

Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.
 

Sample Input
2 5 2 1 9 3 7 2 5 9 0 6 6 3 7 6 0 10 11 35 67 23 2 29 29 58 22 30 67 69 36 56 93 62 42 11 67 73 29 68 19 21 72 37 84 82 24 98
 

Sample Output
9.2195444573 54.5893762558
鞍山现场赛第签到题,超级水!! 求最大难度,难度为相邻两点的距离除以时间差。
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <math.h>
#include <algorithm>
#include <vector>
#include <map>
#include <queue>
#include <stack>
#define PI acos(-1.0)
#define eps 1e-8
#define LL long long
#define moo 1000000007
#define INF -999999999
using namespace std;
long long a[1005],b[1005],c[1005];
double d[1005];
int main()
{
    int t;
    int n;
    scanf("%d",&t);
    while(t--)
    {

        scanf("%d",&n);
        double ans=0;
        for(int i=0;i<n;i++)
        {
            scanf("%I64d%I64d%I64d",&a[i],&b[i],&c[i]);
        }
        for(int i=1;i<n;i++)
        {
                d[i]=sqrt((b[i]-b[i-1])*(b[i]-b[i-1])+(c[i]-c[i-1])*(c[i]-c[i-1]))/(a[i]-a[i-1]);
                ans=max(d[i],ans);
        }
        printf("%.10f\n",ans);
    }
}

























以上是关于hdu 5078的主要内容,如果未能解决你的问题,请参考以下文章

hdu 5078 Osu! (2014 acm 亚洲区域赛鞍山 I)

在安装MSXML 版本6.10.1129.0的时候找不到F5078F18-C551-11D3-89B9-0000F81FE221怎么办呢?

HDU4057 Rescue the Rabbit(AC自动机+状压DP)

HDU3247 Resource Archiver(AC自动机+BFS+DP)

Office2010安装需要MSXML版本6.10.1129.0的方法

POJ - 2778 ~ HDU - 2243 AC自动机+矩阵快速幂