hdu 5078 Osu! (2014 acm 亚洲区域赛鞍山 I)

Posted zsychanpin

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 5078 Osu! (2014 acm 亚洲区域赛鞍山 I)相关的知识,希望对你有一定的参考价值。

题目链接:http://acm.hdu.edu.cn/showproblem.php?

pid=5078


Osu!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 180    Accepted Submission(s): 114
Special Judge


Problem Description
Osu! is a very popular music game. Basically, it is a game about clicking. Some points will appear on the screen at some time, and you have to click them at a correct time.

技术分享

Now, you want to write an algorithm to estimate how diffecult a game is.

To simplify the things, in a game consisting of N points, point i will occur at time ti at place (xi, yi), and you should click it exactly at ti at (xi, yi). That means you should move your cursor from point i to point i+1. This movement is called a jump, and the difficulty of a jump is just the distance between point i and point i+1 divided by the time between ti and ti+1. And the difficulty of a game is simply the difficulty of the most difficult jump in the game.

Now, given a description of a game, please calculate its difficulty.
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 1000) denoting the number of the points in the game.  Then N lines follow, the i-th line consisting of 3 space-separated integers, ti(0 ≤ ti < ti+1 ≤ 106), xi, and yi (0 ≤ xi, yi ≤ 106) as mentioned above.
 

Output
For each test case, output the answer in one line.

Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.
 

Sample Input
2 5 2 1 9 3 7 2 5 9 0 6 6 3 7 6 0 10 11 35 67 23 2 29 29 58 22 30 67 69 36 56 93 62 42 11 67 73 29 68 19 21 72 37 84 82 24 98
 

Sample Output
9.2195444573 54.5893762558
Hint
In memory of the best osu! player ever Cookiezi.
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  5081 5080 5079 5077 5076 
 

Statistic | Submit | Discuss | Note


鞍山的签到题,记得把类型定义成long long 防止溢出即可了。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<cstdlib>
using namespace std;
#define CLR(A) memset(A,0,sizeof(A))
typedef long long ll;
const int MAXN=1010;
ll x[MAXN],y[MAXN],t[MAXN];
int main(){
    int T;
    cin>>T;
    while(T--){
        int n;
        cin>>n;
        for(int i=0;i<n;i++) cin>>t[i]>>x[i]>>y[i];
        double ans=0;
        for(int i=1;i<n;i++){
            double tmp=sqrt((x[i]-x[i-1])*(x[i]-x[i-1])+(y[i]-y[i-1])*(y[i]-y[i-1]))/(double)(t[i]-t[i-1]);
            ans=max(ans,tmp);
        }
        printf("%.10lf\n",ans);
    }
    return 0;
}


































以上是关于hdu 5078 Osu! (2014 acm 亚洲区域赛鞍山 I)的主要内容,如果未能解决你的问题,请参考以下文章

hdu 5078

hdu 5080 2014ACM/ICPC鞍山K题 polya计数

hdu 5016 点分治(2014 ACM/ICPC Asia Regional Xi'an Online)

HDU 5112 A Curious Matt (2014ACM/ICPC亚洲区北京站-重现赛)

2014ACM/ICPC亚洲区北京站题解

hdu 2014