usaco题目分享——Agri-Net

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了usaco题目分享——Agri-Net相关的知识,希望对你有一定的参考价值。

Agri-Net
Russ Cox

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.

Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.

Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.

The distance between any two farms will not exceed 100,000.

PROGRAM NAME: agrinet

INPUT FORMAT

Line 1: The number of farms, N (3 <= N <= 100).
Line 2..end: The subsequent lines contain the N x N connectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

SAMPLE INPUT (file agrinet.in)

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

OUTPUT FORMAT

The single output contains the integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

SAMPLE OUTPUT (file agrinet.out)

28

嗯,最小生成树。
(我空间开小了,WA了四五次......)
可以用于练手。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int n,o,ans;
int fa[10005];
struct like
{
    int u,v;
    int w;
    bool operator < (like l) const
    {
        return w<l.w;
    }
}f[10005];
int find(int x)
{
    if(x!=fa[x]) fa[x]=find(fa[x]);
    return fa[x];
}
int main()
{
    freopen("agrinet.in","r",stdin);
    freopen("agrinet.out","w",stdout);
    int i,j;
    scanf("%d",&n);
    int a,b;
    for(i=1;i<=n;++i)
    {
        fa[i]=i;
        for(j=1;j<=n;++j)
        {
            scanf("%d",&a);
            if(i<j)
            {
                o++;
                f[o].u=i;
                f[o].v=j;
                f[o].w=a;
            }
        }
    }
    sort(f+1,f+1+o);
    int k=0;
    for(i=1;i<=o;++i)
    {
        a=f[i].u;
        b=f[i].v;
        a=find(a);
        b=find(b);
        if(fa[a]==fa[b]) continue;
        fa[a]=fa[b];
        k++;
        ans+=f[i].w;
        if(k==n-1) break;
    }
    printf("%d\n",ans);
    return 0;
}

 

以上是关于usaco题目分享——Agri-Net的主要内容,如果未能解决你的问题,请参考以下文章

usaco题目分享——Bessie Come Home

usaco题目分享——Agri-Net

usaco题目分享——Controlling Companies

洛谷 P3040 [USACO12JAN]贝尔分享Bale Share

DTOJ #4492. 「USACO 2018 Jan」MooTube

usaco 怎么测评