HDU4355-Party All the Time-三分

Posted Persistent.

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU4355-Party All the Time-三分相关的知识,希望对你有一定的参考价值。

不想好好写这个了。。。

Party All the Time

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5462    Accepted Submission(s): 1707


Problem Description
In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S3*W units if it walks a distance of S kilometers.
Now give you every spirit‘s weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.
 

 

Input
The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x[i]<=x[i+1] for all i(1<=i<N). The i-th line contains two real number : Xi,Wi, representing the location and the weight of the i-th spirit. ( |xi|<=106, 0<wi<15 )
 

 

Output
For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.
 

 

Sample Input
1
4
0.6 5
3.9 10
5.1 7
8.4 10
 
Sample Output
Case #1: 832
 
 
直接代码了。。。
#include<bits/stdc++.h>
using namespace std;
#define N 50500
struct node{
    double p;
    double w;
}a[N];
int n;
double sum(double mid){
    double sum=0.0;
    for(int i=0;i<n;i++){
        double s=fabs(a[i].p-mid);
        sum+=s*s*s*a[i].w;
    }
    return sum;
}
double sanfen(double l,double r){
    double mid,midd,ans1,ans2,left,right;
    left=l;right=r;
    while(left+0.000000001<right){
        mid=(left+right)/2.0;
        midd=(mid+right)/2.0;
        ans1=sum(mid);
        ans2=sum(midd);
        if(ans1<ans2)right=midd;
        else left=mid;
    }
    return left;
}
int main(){
    int t,num;
    double left,right,ans,m;
    num=0;
    while(~scanf("%d",&t)){
      while(t--){
            num++;
            left=1e5;right=1e-5;
            scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%lf%lf",&a[i].p,&a[i].w);
            left=min(left,a[i].p);
            right=max(right,a[i].p);
        }
        m=sanfen(left,right);
        ans=sum(m);
        printf("Case #%d: %.0lf\n",num,ans);
     }
    }
     return 0;
}

我好饿。。。咕~~(╯﹏╰)b

没力气写了。(*/ω\*)

。。。

 

以上是关于HDU4355-Party All the Time-三分的主要内容,如果未能解决你的问题,请参考以下文章

HDU 4355 Party All the Time 三分算法

HDU 4355 Party All the Time(三分|二分)

HDOJ4355-Party All the Time(三分)

HDU5742 It's All In The Mind(思维题,水题)

The All-purpose Zero---hdu5773(LIS变形)

I - Party All the Time (HDU - 4355)