HDU_3792_(素数筛+树状数组)

Posted Jason333

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU_3792_(素数筛+树状数组)相关的知识,希望对你有一定的参考价值。

Twin Prime Conjecture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3280    Accepted Submission(s): 1162


Problem Description
If we define dn as: dn = pn+1-pn, where pi is the i-th prime. It is easy to see that d1 = 1 and dn=even for n>1. Twin Prime Conjecture states that "There are infinite consecutive primes differing by 2".
Now given any positive integer N (< 10^5), you are supposed to count the number of twin primes which are no greater than N.
 

 

Input
Your program must read test cases from standard input.
The input file consists of several test cases. Each case occupies a line which contains one integer N. The input is finished by a negative N.
 

 

Output
For each test case, your program must output to standard output. Print in one line the number of twin primes which are no greater than N.
 

 

Sample Input
1
5
20
-2
 

 

Sample Output
0
1
4

题意:输入n,求小于n的孪生素数对有多少个。
 
素数筛+树状数组
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
#define N 100005

int s[N];
int prime[N],cntp;
bool isNot[N];

void getPrime()
{
    for(int i=2;i<=N;i++)
    {
        if(isNot[i]==0)
        {
            prime[cntp++]=i;
            for(int j=2;i*j<=N;j++)
                isNot[i*j]=1;
        }
    }
}
int lowbit(int x)
{
    return x&(-x);
}

void add(int x,int num)
{
    while(x<=N)
    {
        s[x]+=num;
        x+=lowbit(x);
    }
}

int sum(int x)
{
    int res=0;
    while(x>0)
    {
        res+=s[x];
        x-=lowbit(x);
    }
    return res;
}

int main()
{
    cntp=1;
    getPrime();
    for(int i=2;i<cntp;i++)
        if(prime[i]-prime[i-1]==2)
            add(prime[i],1);
    int n;
    while(scanf("%d",&n)!=EOF&&n>0)
    {
        printf("%d\n",sum(n));
    }
    return 0;
}

 

以上是关于HDU_3792_(素数筛+树状数组)的主要内容,如果未能解决你的问题,请参考以下文章

HDU_4456_二维树状数组

[题解](区间质数筛)POJ_2689 Prime Distance

HDU6069 Multi-4 素数筛

HDU 6096 String(AC自动机+树状数组)

[luoguP1835] 素数密度_NOI导刊2011提高(04)(素数筛)

区间素数个数(Min_25筛)