zoj 3212 K-Nice(构造)

Posted -凡-尘

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了zoj 3212 K-Nice(构造)相关的知识,希望对你有一定的参考价值。

K-Nice

Time Limit: 1 Second      Memory Limit: 32768 KB      Special Judge

This is a super simple problem. The description is simple, the solution is simple. If you believe so, just read it on. Or if you don‘t, just pretend that you can‘t see this one.

We say an element is inside a matrix if it has four neighboring elements in the matrix (Those at the corner have two and on the edge have three). An element inside a matrix is called "nice" when its value equals the sum of its four neighbors. A matrix is called "k-nice" if and only if k of the elements inside the matrix are "nice".

Now given the size of the matrix and the value of k, you are to output any one of the "k-nice" matrix of the given size. It is guaranteed that there is always a solution to every test case.

Input

The first line of the input contains an integer T (1 <= T <= 8500) followed by T test cases. Each case contains three integers nmk (2 <= nm <= 15, 0 <= k <= (n - 2) * (m - 2)) indicating the matrix size n * m and it the "nice"-degree k.

Output

For each test case, output a matrix with n lines each containing m elements separated by a space (no extra space at the end of the line). The absolute value of the elements in the matrix should not be greater than 10000.

Sample Input

2
4 5 3
5 5 3

Sample Output

2 1 3 1 1
4 8 2 6 1
1 1 9 2 9
2 2 4 4 3
0 1 2 3 0
0 4 5 6 0
0 0 0 0 0
0 0 0 0 0
0 0 0 0 0

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int t,n,m,k;
int mp[20][20];
int main()
{
    while(~scanf("%d",&t))
    {
     for(;t>0;t--)
     {
         scanf("%d%d%d",&n,&m,&k);
         k=(n-2)*(m-2)-k;
         for(int i=1;i<=n;i++)
         {
             printf("0");
             for(int j=2;j<m;j++)
                if (k>0) printf(" %d",k--);
                 else printf(" 0");
            printf(" 0\n");
         }
     }
    }
    return 0;
}

 

以上是关于zoj 3212 K-Nice(构造)的主要内容,如果未能解决你的问题,请参考以下文章

ZOJ4061Magic Multiplication(构造)

在 Visual Studio 中创建构造函数的代码片段或快捷方式

NEFU 506&&ZOJ 3353 Chess Board (四种构造的高斯消元)

BZOJ3212: Pku3468 A Simple Problem with Integers

bzoj3212: Pku3468 A Simple Problem with Integers(线段树)

zoj 3963 heap partion