Number Sequence (HDU 1711)

Posted Soda

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Number Sequence (HDU 1711)相关的知识,希望对你有一定的参考价值。

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24116    Accepted Submission(s): 10232


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 
Sample Output
6
-1
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int len1,len2,a[1000005],b[10005],ne[10005];
void getnext()
{
    int i,j;
    ne[0]=0;ne[1]=0;
    for(i=1;i<len2;i++)
    {
        j=ne[i];
        while(j&&b[i]!=b[j])j=ne[j];
        if(b[i]==b[j])ne[i+1]=j+1;
        else ne[i+1]=0;
    }
}

void kmp()
{
    int i,j=0;
    int flag=0;
    for(i=0;i<len1;i++)
    {
        while(j&&a[i]!=b[j])j=ne[j];
        if(a[i]==b[j])j++;
        if(j==len2)
        {
            flag=1;
            printf("%d\n",i-len2+2);
            break;
        }
    }
    if(!flag)cout<<-1;
}

int main()
{
    int T,i;
    cin>>T;
    while(T--)
    {
        cin>>len1>>len2;
        for(i=0;i<len1;i++)cin>>a[i];
        for(i=0;i<len2;i++)cin>>b[i];
        getnext();
        kmp();
    }
    return 0;
}

 


 

以上是关于Number Sequence (HDU 1711)的主要内容,如果未能解决你的问题,请参考以下文章

Number Sequence (HDU 1711)

HDU——T 1711 Number Sequence

Number Sequence HDU - 1711

hdu[1711]number sequence

hdu 1711 Number Sequence

HDU - 1711 Number Sequence