Who's in the Middle[HDU1157]
Posted PoorLitt1eThin9
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Who's in the Middle[HDU1157]相关的知识,希望对你有一定的参考价值。
Who\'s in the Middle
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16668 Accepted Submission(s):
7471
Problem Description
FJ is surveying his herd to find the most average cow.
He wants to know how much milk this \'median\' cow gives: half of the cows give as
much or more than the median; half give as much or less.
Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
Input
* Line 1: A single integer N
* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
Output
* Line 1: A single integer that is the median milk
output.
Sample Input
5
2
4
1
3
5
Sample Output
3
Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.#include<stdio.h>
#include<algorithm>
using namespace std;
int a[10010];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n);
printf("%d\\n",a[n/2]);
}
return 0;
}
以上是关于Who's in the Middle[HDU1157]的主要内容,如果未能解决你的问题,请参考以下文章
POJ 2388Who's in the Middle(水~奇数个数排序求中位数)
bzoj 1753: [Usaco2005 qua]Who's in the Middle排序
A who's who of blockchain investors and startups in China