POJ_3279_(dfs)(状态)

Posted Jason333

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ_3279_(dfs)(状态)相关的知识,希望对你有一定的参考价值。

---恢复内容开始---

Fliptile
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8219   Accepted: 3071

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0



题意:给定一个只含0和1的矩阵,每次可以翻转一个点以及它周围的点(上下左右)。问最少需要多少步。
一来没什么头绪,看了题解,说,枚举第一行的所有状态,然后往后推后面的行。以为自己肯定搞不出来,结果还搞出来了,开心!
不过这题被别人归类在简单题里。。。永远都是菜鸟。。。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 20
#define INF 99999999

int n,m;
int gra[N][N],tmp[N][N],tmp1[N][N];

void flip(int r,int i)
{
    gra[r][i]^=1;
    if(i-1>=0)
        gra[r][i-1]^=1;
    if(i+1<m)
        gra[r][i+1]^=1;
    if(r-1>=0)
        gra[r-1][i]^=1;
    if(r+1<m)
        gra[r+1][i]^=1;
}

void change(int r,int x)
{
    for(int i=0; i<m; i++)
    {
        if((1<<(m-1-i))&x)
            flip(r,i);
    }
}

int cnt,res=INF;
void dfs(int r)
{
    if(r==n)
    {
        int flag=1;
        for(int i=0; i<m; i++)
            if(gra[n-1][i]==1)
            {
                flag=0;
                break;
            }
        if(flag)
        {
            if(res>cnt)
            {
                res=cnt;
                for(int i=0; i<n; i++)
                    for(int j=0; j<m; j++)
                        tmp[i][j]=tmp1[i][j];
            }
        }
        return;
    }
    int x=0;
    memset(tmp1[r],0,sizeof(tmp[r]));
    for(int i=0; i<m; i++)
    {
        if(gra[r-1][i]==1)
        {
            tmp1[r][i]=1;
            cnt++;
            x+=(1<<(m-1-i));
        }
    }
    change(r,x);
    dfs(r+1);
    change(r,x);
}

int main()
{

    scanf("%d%d",&n,&m);
    for(int i=0; i<n; i++)
        for(int j=0; j<m; j++)
            scanf("%d",&gra[i][j]);
    cnt=0;
    res=INF;
    for(int i=0; i<(1<<m); i++)
    {
            cnt=0;
        memset(tmp1[0],0,sizeof(tmp[1]));
        for(int j=0; j<m; j++)
        {
            if((1<<j)&i)
            {
                cnt++;
                tmp1[0][m-1-j]++;
            }
        }
        change(0,i);
        dfs(1);
        change(0,i);
    }
    if(res<INF)
    {
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
            {
                printf("%d",tmp[i][j]);
                if(j==m-1)
                    printf("\n");
                else
                    printf(" ");
            }
    }
    else
        printf("IMPOSSIBLE\n");
    return 0;
}

 

 

---恢复内容结束---

以上是关于POJ_3279_(dfs)(状态)的主要内容,如果未能解决你的问题,请参考以下文章

Fliptile POJ-3279 DFS

poj3279(dfs+二进制枚举思路)

(POJ-3279)Fliptile (dfs经典---也可以枚举)

POJ 3279 Fliptile(DFS+反转)

POJ - 3279 - Fliptile(暴力递推)

Fliptile POJ - 3279(状态压缩)