POJ2406Power Strings[KMP 失配函数]

Posted Candy?

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ2406Power Strings[KMP 失配函数]相关的知识,希望对你有一定的参考价值。

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 45005   Accepted: 18792

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source


只需要求n的错位部分n-f[n]是不是循环节
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e6+5;
int n,f[N];
char p[N];
int main(){
    int cas=0;
    while(true){
        scanf("%s",p);
        n=strlen(p);
        if(p[0]==.) break;
        f[0]=f[1]=0;
        for(int i=1;i<n;i++){
            int j=f[i];
            while(j&&p[j]!=p[i]) j=f[j];
            f[i+1]=p[j]==p[i]?j+1:0;
        }
        if(n%(n-f[n])==0) printf("%d\n",n/(n-f[n]));
        else printf("1\n");
    }
}

 

以上是关于POJ2406Power Strings[KMP 失配函数]的主要内容,如果未能解决你的问题,请参考以下文章

poj 2406 Power Strings(KMP)

POJ 2406 - Power Strings - [KMP求最小循环节]

POJ2406Power Strings[KMP 失配函数]

POJ2406-Power Strings(kmp循环节)

kmp+最小循环节poj 2406 Power Strings

POJ2406-Power Strings-KMP循环节/哈希循环节