HDU 1096 A+B for Input-Output Practice (VIII)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1096 A+B for Input-Output Practice (VIII)相关的知识,希望对你有一定的参考价值。

Problem Description
Your task is to calculate the sum of some integers.
 
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 
Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
 
Sample Output
10
 
15
 
6
 
题意:输入n,代表n组数据,每组数据输入m及m个数,求m个数的和
注意:两组数据之间输出一个空行
 
#include <stdio.h>
int main()
{
    int n, sum, m, i, a;
    while (scanf ("%d", &n)!=EOF)
    {
        while(n--)
        {
        scanf ("%d", &m);
        sum = 0;
        for (i=1;i<=m;i++)
        {
            scanf ("%d", &a);
            sum += a;
        }
        printf ("%d\n", sum);
        if(n != 0) printf("\n");
        }
    }
    return 0;
}

 

以上是关于HDU 1096 A+B for Input-Output Practice (VIII)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1096 A+B for Input-Output Practice (VIII)

Hdu 1096 A+B for Input-Output Practice (VIII)

(HDU)1096 --A+B for Input-Output Practice (VIII)(输入输出练习(VIII))

hdu 1000+1089~1096 题解

HDU——算法练习1000 1089-1096

1096 A+B for Input-Output Practice (VIII)