POJ 3422Kaka's Matrix Travels(最小费用最大流)

Posted 贱人方

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 3422Kaka's Matrix Travels(最小费用最大流)相关的知识,希望对你有一定的参考价值。

                                                        Kaka\'s Matrix Travels
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9460   Accepted: 3844

Description

On an N × N chessboard with a non-negative number in each grid, Kaka starts his matrix travels with SUM = 0. For each travel, Kaka moves one rook from the left-upper grid to the right-bottom one, taking care that the rook moves only to the right or down. Kaka adds the number to SUM in each grid the rook visited, and replaces it with zero. It is not difficult to know the maximum SUM Kaka can obtain for his first travel. Now Kaka is wondering what is the maximum SUM he can obtain after his Kth travel. Note the SUM is accumulative during the K travels.

Input

The first line contains two integers N and K (1 ≤ N ≤ 50, 0 ≤ K ≤ 10) described above. The following N lines represents the matrix. You can assume the numbers in the matrix are no more than 1000.

Output

The maximum SUM Kaka can obtain after his Kth travel.

Sample Input

3 2
1 2 3
0 2 1
1 4 2

Sample Output

15

Source

【分析】下面是模板。

 

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <time.h>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define inf 0x7fffffff
#define mod 10000
#define met(a,b) memset(a,b,sizeof a)
typedef long long ll;
using namespace std;
const int N = 100;
const int M = 100000;
struct Edge {
    int to,next,cap,flow,cost;
} edge[M];
int head[N],tol;
int pre[N],dis[N];
bool vis[N];
int T;//节点总个数,节点编号从0~N-1
void init(int n) {
    T = n;
    tol = 0;
    memset(head,-1,sizeof(head));
}
void addedge(int u,int v,int cap,int cost) {
    edge[tol].to = v;
    edge[tol].cap = cap;
    edge[tol].cost = cost;
    edge[tol].flow = 0;
    edge[tol].next = head[u];
    head[u] = tol++;
    edge[tol].to = u;
    edge[tol].cap = 0;
    edge[tol].cost = -cost;
    edge[tol].flow = 0;
    edge[tol].next = head[v];
    head[v] = tol++;
}
bool spfa(int s,int t) {
    queue<int>q;
    for(int i = 0; i < N; i++) {
        dis[i] = inf;
        vis[i] = false;
        pre[i] = -1;
    }
    dis[s] = 0;
    vis[s] = true;
    q.push(s);
    while(!q.empty()) {
        int u = q.front();
        q.pop();
        vis[u] = false;
        for(int i = head[u]; i != -1; i = edge[i].next) {
            int v = edge[i].to;
            if(edge[i].cap > edge[i].flow &&
                    dis[v] > dis[u] + edge[i].cost ) {
                dis[v] = dis[u] + edge[i].cost;
                pre[v] = i;
                if(!vis[v]) {
                    vis[v] = true;
                    q.push(v);
                }
            }
        }
    }
    if(pre[t] == -1)return false;
    else return true;
}
//返回的是最大流,cost存的是最小费用
int minCostMaxflow(int s,int t,int &cost) {
    int flow = 0;
    cost = 0;
    while(spfa(s,t)) {
        int Min = inf;
        for(int i = pre[t]; i != -1; i = pre[edge[i^1].to]) {
            if(Min > edge[i].cap - edge[i].flow)
                Min = edge[i].cap - edge[i].flow;
        }
        for(int i = pre[t]; i != -1; i = pre[edge[i^1].to]) {
            edge[i].flow += Min;
            edge[i^1].flow -= Min;
            cost += edge[i].cost * Min;
        }
        flow += Min;
    }
    return flow;
}

int a[N][N];
int main() {
    int n,k;
    while(~scanf("%d%d",&n,&k) ) {
        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++)
                scanf("%d",&a[i][j]);
        init(2*n*n+2);
        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++) {
                addedge(n*i+j+1,n*n+n*i+j+1,1,-a[i][j]);
                addedge(n*i+j+1,n*n+n*i+j+1,inf,0);
            }

        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++) {
                if(i < n-1)
                    addedge(n*n+n*i+j+1,n*(i+1)+j+1,inf,0);
                if(j < n-1)
                    addedge(n*n+n*i+j+1,n*i+j+1+1,inf,0);
            }
        addedge(0,1,k,0);
        addedge(2*n*n,2*n*n+1,inf,0);
        int cost;
        minCostMaxflow(0,2*n*n+1,cost);
        printf("%d\\n",-cost);
    }
    return 0;
}
View Code

 

以上是关于POJ 3422Kaka's Matrix Travels(最小费用最大流)的主要内容,如果未能解决你的问题,请参考以下文章

poj3422 Kaka's Matrix Travels

POJ3422 Kaka&#39;s Matrix Travels 最大费用最大流

POJ3422:Kaka's Matrix Travels——题解

POJ3422 Kaka's Matrix Travels[?????????]

POJ 3422Kaka's Matrix Travels(最小费用最大流)

[poj] 3422 Kaka's Matrix Travels || 最小费用最大流