HDU 1213 How Many Tables(并查集)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1213 How Many Tables(并查集)相关的知识,希望对你有一定的参考价值。

传送门

Description

Today is Ignatius‘ birthday. He invites a lot of friends. Now it‘s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2 
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2 
4

思路

需要的最少桌子数即为联通块的个数。
 
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1005;
int fa[maxn],flag[maxn];

int find(int x)
{
    int r = x;
    while (r != fa[r])    r = fa[r];
    int i = x,j;
    while (i != r)
    {
        j = fa[i];
        fa[i] = r;
        i = j;
    }
    return r;
} 

void unite(int x,int y)
{
    x = find(x),y = find(y);
    if (x != y)    fa[x] = y;
}

int main()
{
    int T;
    scanf("%d",&T);
    while (T--)
    {
        int N,M,x,y,res = 0;
        memset(flag,false,sizeof(flag));
        scanf("%d%d",&N,&M);
        for (int i = 1;i <= N;i++)    fa[i] = i;
        while (M--)
        {
            scanf("%d%d",&x,&y);
            unite(x,y);
        }
        for (int i = 1;i <= N;i++)    if (find(i) == i)    res++;
        printf("%d\n",res);
    }
    return 0;
}

  

以上是关于HDU 1213 How Many Tables(并查集)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1213 How Many Tables(模板——并查集)

HDU - 1213 How Many Tables(并查集)

HDU - 1213 How Many Tables [并查集]

HDU 1213 How Many Tables [并查集]

HDU 1213 How Many Tables(并查集)

HDU 1213 How Many Tables