hdu 5904 LCIS dp

Posted xjhz

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 5904 LCIS dp相关的知识,希望对你有一定的参考价值。

LCIS

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


Problem Description
Alex has two sequences a1,a2,...,an and b1,b2,...,bm. He wants find a longest common subsequence that consists of consecutive values in increasing order.
 

 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains two integers n and m (1n,m100000) -- the length of two sequences. The second line contains n integers: a1,a2,...,an (1ai106). The third line contains n integers: b1,b2,...,bm (1bi106).

There are at most 1000 test cases and the sum of n and m does not exceed 2×106.
 

 

Output
For each test case, output the length of longest common subsequence that consists of consecutive values in increasing order.
 

 

Sample Input
3 3 3 1 2 3 3 2 1 10 5 1 23 2 32 4 3 4 5 6 1 1 2 3 4 5 1 1 2 1
 

 

Sample Output
1 5 0
 

 

Source
#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define pi (4*atan(1.0))
const int N=1e5+10,M=1e6+1010,inf=1e9+10,mod=1e9+7;
const ll INF=1e18+10;
int n,m;
int a[N],b[N];
int dpn[M],dpm[M];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int ans=0;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            dpn[a[i]]=max(dpn[a[i]],dpn[a[i]-1]+1);
        }
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&b[i]);
            dpm[b[i]]=max(dpm[b[i]],dpm[b[i]-1]+1);
            ans=max(ans,min(dpm[b[i]],dpn[b[i]]));
        }
        for(int i=1;i<=n;i++)
        dpn[a[i]]=0;
        for(int i=1;i<=m;i++)
        dpm[b[i]]=0;
        printf("%d\n",ans);
    }
}

 

以上是关于hdu 5904 LCIS dp的主要内容,如果未能解决你的问题,请参考以下文章

HDU 5904 LCIS DP

[HDU5904]LCIS(DP)

HDU 5904 - LCIS (BestCoder Round #87)

HDU 5904 LCIS

hdu-5904 LCIS(水题)

HDU 5904 LCIS (最长公共上升序列)