洛谷P1204 [USACO1.2]挤牛奶Milking Cows

Posted zbtrs

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了洛谷P1204 [USACO1.2]挤牛奶Milking Cows相关的知识,希望对你有一定的参考价值。

P1204 [USACO1.2]挤牛奶Milking Cows

  •  
  • 474通过
  • 1.4K提交
  • 题目提供者该用户不存在
  • 标签USACO
  • 难度普及-

 提交  讨论  题解  

最新讨论

  • 请各位帮忙看下程序 错误 谢…
  • 求大神扫一眼,模拟算法
  • 求帮看看哪儿错
  • 帮忙看看为什么不过
  • 帮我看看哪里错了,挤牛奶,…
  • 帮我看看哪里错了

题目描述

三个农民每天清晨5点起床,然后去牛棚给3头牛挤奶。第一个农民在300秒(从5点开始计时)给他的牛挤奶,一直到1000秒。第二个农民在700秒开始,在 1200秒结束。第三个农民在1500秒开始2100秒结束。期间最长的至少有一个农民在挤奶的连续时间为900秒(从300秒到1200秒),而最长的无人挤奶的连续时间(从挤奶开始一直到挤奶结束)为300秒(从1200秒到1500秒)。

你的任务是编一个程序,读入一个有N个农民(1 <= N <= 5000)挤N头牛的工作时间列表,计算以下两点(均以秒为单位):

最长至少有一人在挤奶的时间段。

最长的无人挤奶的时间段。(从有人挤奶开始算起)

输入输出格式

输入格式:

Line 1:

一个整数N。

Lines 2..N+1:

每行两个小于1000000的非负整数,表示一个农民的开始时刻与结束时刻。

输出格式:

一行,两个整数,即题目所要求的两个答案。

输入输出样例

输入样例#1

3

300 1000

700 1200

1500 2100

输出样例#1

900 300

说明

题目翻译来自NOCOW。

USACO Training Section 1.2

分析:很简单的一道模拟题,枚举每个时间点看看是否在挤奶,最后枚举判断一下即可.

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int a1[1000010],n,maxx = -1,minn = 1000010,ans1,ans2,ans11,ans22;

int main()
{
    scanf("%d", &n);
    for (int i = 1; i <= n; i++)
    {
        int a, b;
        scanf("%d%d", &a, &b);
        if (a < minn)
            minn = a;
        if (b > maxx)
            maxx = b;
        for (int j = a; j < b; j++)
            a1[j] = 1;
    }
    for (int i = minn; i <= maxx; i++)
    {
        if (a1[i] == 1)
            ans1++;
        else
            if (a1[i] == 0)
                ans2++;
        if (a1[i + 1] == 1)
        {
            if (ans2 > ans22)
                ans22 = ans2;
            ans2 = 0;
        }
        else
            if (a1[i + 1] == 0)
            {
            if (ans1 > ans11)
                ans11 = ans1;
            ans1 = 0;
            }
    }
    if (ans1 > ans11)
        ans11 = ans1;
    if (ans2 > ans22)
        ans22 = ans2;
    if (ans11 == 1)
        ans11 = 0;
    if (ans22 == 1)
        ans22 = 0;
    printf("%d %d", ans11, ans22);

    return 0;
}

 

以上是关于洛谷P1204 [USACO1.2]挤牛奶Milking Cows的主要内容,如果未能解决你的问题,请参考以下文章

题解Luogu P1204 [USACO1.2]挤牛奶Milking Cows

AC日记——挤牛奶 洛谷 P1204

[USACO1.2]挤牛奶Milking Cows

Cogs 465. 挤牛奶

洛谷P2852 [USACO06DEC]牛奶模式Milk Patterns

洛谷 P1208 [USACO1.3]混合牛奶 Mixing Milk