POJ 3254Corn Fields

Posted -凡-尘

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 3254Corn Fields相关的知识,希望对你有一定的参考价值。

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can‘t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows: 
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
 
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int mod=100000000;
int dp[14][5000],mp[14][14];
int n,m;
int main()
{
    scanf("%d%d",&m,&n);
    for(int i=1;i<=m;i++)
     for(int j=1;j<=n;j++)
      scanf("%d",&mp[i][j]);
    dp[0][0]=1;
    for(int i=1;i<=m;i++)
    {
        int s=0;
        for(int j=n;j>=1;j--) {s=s<<1; s+=(mp[i][j]+1)%2;}
        //这里不能写成s=s<<1+(mp[i][j]+1)%2; 这样的位运算出来的结果是错误的
       // printf("%d\n",s);
         for(int j=0;j<1<<n;j++)
        {
            if (j&(j>>1)) continue; //判断是否水平相邻了
            if (j&s) continue;  //判断放的位置是不是原来就是肥料丰富的
            for(int k=0;k<1<<n;k++)
            {
                if (j&k) continue;
                dp[i][j]=(dp[i][j]+dp[i-1][k])%mod;
            }
        }
    }
    /*for(int i=1;i<=m;i++)
   {
      for(int j=0;j<1<<n;j++)
       printf("%d ",dp[i][j]);
     printf("\n");
   }*/
    int ans=0;
    for(int i=0;i<1<<n;i++)
        ans=(ans%mod+dp[m][i]%mod)%mod;
    printf("%d\n",ans);
    return 0;
}

 

以上是关于POJ 3254Corn Fields的主要内容,如果未能解决你的问题,请参考以下文章

POJ 3254 Corn Fields

POJ 3254Corn Fields

POJ3254Corn Fields

POJ 3254 Corn Fields(状压DP)

POJ 3254 Corn Fields (状压DP)

POJ 3254 Corn Fields(状压dp)