LightOJ 1234 Harmonic Number (打表)

Posted Ritchie丶

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了LightOJ 1234 Harmonic Number (打表)相关的知识,希望对你有一定的参考价值。

Harmonic Number
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

In this problem, you are given n, you have to find Hn.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

题意如题。

题解:考察超内存问题,要分组存储,否则会超内存。

#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;
const int maxn=1e8+5;
double a[maxn/1000+5]; //注意+5
void get()
{
    double sum=1.0;
    a[0]=0;
    a[1]=1.0;
    for(int i=2;i<=maxn;i++)
    {
        sum+=1.0/double(i);
        if(i%1000==0)
            a[i/1000]=sum;
    }
}
int main()
{
    get();
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int b=n/1000;
        double ans=a[b];
        for(int i=b*1000+1;i<=n;i++) //注意是b*1000
        ans+=1.0/double(i);
        printf("Case %d: %.10lf\\n",cas++,ans);
    }
    return 0;
}

 

以上是关于LightOJ 1234 Harmonic Number (打表)的主要内容,如果未能解决你的问题,请参考以下文章

LightOJ 1234Harmonic Number

Harmonic Number LightOJ - 1234 ??????????????????

LightOJ1234 Harmonic Number 调和级数求和

I - Harmonic Number LightOJ - 1234 (分段打表+暴力)

Light oj 1234 - Harmonic Number

1245 - Harmonic Number (II)---LightOJ1245