最短路径(巧妙的矩阵交换)

Posted nonames

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了最短路径(巧妙的矩阵交换)相关的知识,希望对你有一定的参考价值。

Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 35984   Accepted: 16104

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow‘s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
题意:去往并返回
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <stdio.h>
#include <queue>
#include <string.h>
#include <vector>
#include <map>
#define ME(x , y) memset(x , y , sizeof(x))
#define SF(n) scanf("%d" , &n)
#define rep(i , n) for(int i = 0 ; i < n ; i ++)
#define INF  0x3f3f3f3f
#define mod 1000000007
using namespace std;
typedef long long ll ;
int n , m ;
int ma[1109][1109];
int dis[1109];
int vis[1109] ;

int d[1109];


void Dijia(int r)

    for(int i = 1 ; i <= n ; i++)
    
        vis[i] = 0 ;
        dis[i] = ma[r][i];
    
    vis[r] = 1 ;
    for(int i = 1 ; i < n ; i++)
    
        int min1 = INF ;
        int pos ;
        for(int j = 1 ; j <= n ; j++)
        
            if(!vis[j] && dis[j] < min1)
            
                min1 = dis[j];
                pos = j ;
            
        
        vis[pos] = 1 ;
        for(int j = 1 ; j <= n ; j++)
        
            if(!vis[j] && dis[j] > dis[pos] + ma[pos][j])
            
                dis[j] = dis[pos] + ma[pos][j];
            
        
    


int main()

    int to ;
    scanf("%d%d%d" , &n , &m , &to);
    int u , v , w ;
    memset(ma , INF , sizeof(ma));
    int ans = 0 ;
    for(int i = 1 ; i <= n ; i++)
        ma[i][i] = 0 ;

    for(int i = 1 ; i <= m ; i++)
    
        scanf("%d%d%d" , &u , &v , &w);
        ma[u][v] = min(w , ma[u][v]);
    
    
    Dijia(to);
    
    for(int i = 1 ; i <= n ; i++)
    
        d[i] = dis[i];
    
    
    for(int i = 1 ; i <= n ; i++)
    
        for(int j = i + 1 ; j <= n ; j++)
        
            int t ;
            t = ma[i][j];
            ma[i][j] = ma[j][i];
            ma[j][i] = t ;
        
    
    
    Dijia(to);
    
    for(int i = 1 ; i <= n ; i++)
    
        ans = max(ans , d[i] + dis[i]);
    

    printf("%d\n" , ans);


    return 0 ;

 

以上是关于最短路径(巧妙的矩阵交换)的主要内容,如果未能解决你的问题,请参考以下文章

1091.二维矩阵中的最短路径

求java实现矩阵图上任意两点的最短路径源码

数据结构与算法图最短路径算法 ( Floyed 算法 | 图最短路径算法使用场景 | 求解图中任意两个点之间的最短路径 | 邻接矩阵存储图数据 | 弗洛伊德算法总结 )

求c++ 程序 网络上两点间的最短路径

最短路径

lingo的最短路径问题,怎么直接从excel文件导入矩阵