[kuangbin带你飞]专题十二 基础DP1 B - Ignatius and the Princess IV

Posted vampire6

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[kuangbin带你飞]专题十二 基础DP1 B - Ignatius and the Princess IV相关的知识,希望对你有一定的参考价值。

B - Ignatius and the Princess IV

题目链接:https://vjudge.net/contest/68966#problem/B

题目:

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can‘t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

InputThe input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
OutputFor each test case, you have to output only one line which contains the special number you have found.
Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1
Sample Output
3
5
题意:给你一些数,求出那个出现次数大于等于(n+1)/2的数
思路:用map来记录每个数出现了几次

//
// Created by hanyu on 2019/8/4.
//
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <set>
#include<math.h>
#include<map>
using namespace std;
typedef long long ll;
const int maxn=1e6+10;
int main()

    int n;
    while(~scanf("%d",&n))
    
        int a[maxn];
        map<int,int>mp;
        for(int i=0;i<n;i++)
        
            scanf("%d",&a[i]);
            mp[a[i]]++;
        
        int m=(n+1)/2;
        for(auto it:mp)
        
            if(it.second>=m)
            
                printf("%d\n",it.first);
                break;
            
        
    
    return 0;

 


1

以上是关于[kuangbin带你飞]专题十二 基础DP1 B - Ignatius and the Princess IV的主要内容,如果未能解决你的问题,请参考以下文章

算法系列学习[kuangbin带你飞]专题十二 基础DP1 G - 免费馅饼

算法系列学习[kuangbin带你飞]专题十二 基础DP1 C - Monkey and Banana

算法系列学习状压dp [kuangbin带你飞]专题十二 基础DP1 D - Doing Homework

算法系列学习[kuangbin带你飞]专题十二 基础DP1 E - Super Jumping! Jumping! Jumping!

算法系列学习[kuangbin带你飞]专题十二 基础DP1 F - Piggy-Bank 完全背包问题

[kuangbin带你飞]专题十二 基础DP1 A - Max Sum Plus Plus HDU - 1024