bzoj 4430: [Nwerc2015]Guessing Camels赌骆驼

Posted lwq12138

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了bzoj 4430: [Nwerc2015]Guessing Camels赌骆驼相关的知识,希望对你有一定的参考价值。

4430: [Nwerc2015]Guessing Camels赌骆

 

Description

 

Jaap, Jan, and Thijs are on a trip to the desert after having attended the ACM ICPC World Finals 2015 in Morocco. The trip included a camel ride, and after returning from the ride, their guide invited them to a big camel race in the evening. The camels they rode will also participate and it is customary to bet on the results of the race.
One of the most interesting bets involves guessing the complete order in which the camels will finish the race. This bet offers the biggest return on your money, since it is also the one that is the hardest to get right.
Jaap, Jan, and Thijs have already placed their bets, but the race will not start until an hour from now, so they are getting bored. They started wondering how many pairs of camels they have put in the same order. If camel cc is before camel d on Jaap‘s, Jan‘s and Thijs‘ bet, it means that all three of them put c and d in the same order. Can you help them to calculate the number of pairs of camels for which this happened?
Jaap,Jan和Thijs在摩洛哥参加完ACMICPC2015全球总决赛后去沙漠进行了一次旅行。旅行包括了骑骆驼。在骑完回来之后,他们的向导邀请他们在晚上去看一场盛大的骆驼赛跑。他们骑的骆驼也会参加,而赌比赛的结果是一个习惯。其中一个最有趣的赌涉及猜测完成比赛的骆驼的完整名单。这个赌可以为你赢得最多的钱,因为它也是最难猜对的。
Jaap,Jan和Thijs已经下了注,但比赛要在一个小时后才开始,所以他们觉得很无聊。他们开始想知道有多少对骆驼他们赌了同样的顺序。如果在他们三人的猜测名单中,骆驼c在骆驼d前,就意味着c和d在他们的名单中有相同的顺序。你能帮他们计算有多少对骆驼是这样的吗?

 

Input

 

The input consists of:
one line with an integer n ( 2≤n≤200000), the number of camels;
one line with n integers a1,…,ana1,…,an ( 1≤ai≤n for all i ), Jaap‘s bet. Here a1 is the camel in the first position of Jaap‘s bet, a2 is the camel in the second position, and so on;
one line with Jan‘s bet, in the same format as Jaap‘s bet;
one line with Thijs‘ bet, in the same format as Jaap‘s bet.
The camels are numbered 1,…,n . Each camel appears exactly once in each bet.
输入包括:
第一行是一个整数n(2<=n<=200000),骆驼的数量。
第二行有n个整数a1…an(1<=ai<=n),是Jaap的下赌名单。a1是名单中第一位,a2是第二位,等等。
第三行是Jan的名单,格式同上。
第四行是Thijs的名单,格式同上。
骆驼从1到n编号,每头骆驼在一份名单中只出现一次。

 

Output

 

Output the number of pairs of camels that appear in the same order in all 3 bets.
输出在三份名单中同样顺序的骆驼有多少对。

 

Sample Input

 

Sample input 1
3
3 2 1
1 2 3
1 2 3
Sample input 2
4
2 3 1 4
2 1 4 3
2 4 3 1

 

Sample Output

 

Sample output 1
0
Sample output 2
3
题解:
先考虑怎么算两个序列不相同的(i,j)个数。
使用树状数组,用id[i]记录a[i]在a数组中的位置,然后倒着循环,

在a数组中以b[i]结尾的个数就是1到i的前缀和,更新就是在id[b[i]]的位置加1,为什么是这样呢???
我们是从尾开始枚举的,

#include<stdio.h>
#include<iostream>
using namespace std;
const int N=200005;
int n,i,a[N],b[N],c[N],t[N],p[N];
long long ans;
void update(int x)
{
    while(x<=n)
    {
        t[x]++;
        x+=x&-x;
    }
}
int solve(int x)
{
    int ans=0;
    while(x>0)
    {
        ans+=t[x];
        x-=x&-x;
    }
    return ans;
}
int main()
{
    scanf("%d",&n);
    for(i=1;i<=n;i++) scanf("%d",&a[i]);
    for(i=1;i<=n;i++) scanf("%d",&b[i]);
    for(i=1;i<=n;i++) scanf("%d",&c[i]);
    for(i=1;i<=n;i++) p[a[i]]=i;
    for(i=n;i>=1;i--)
    {
        ans+=solve(p[b[i]]);
        update(p[b[i]]);
    }
    for(i=1;i<=n;i++) p[b[i]]=i,t[i]=0;
    for(i=n;i>=1;i--)
    {
        ans+=solve(p[c[i]]);
        update(p[c[i]]);
    }
    for(i=1;i<=n;i++) p[c[i]]=i,t[i]=0;
    for(i=n;i>=1;i--)
    {
        ans+=solve(p[a[i]]);
        update(p[a[i]]);
    }
    cout<<((1LL*n*(n-1)-ans)>>1);
    return 0;
}

 

 

以上是关于bzoj 4430: [Nwerc2015]Guessing Camels赌骆驼的主要内容,如果未能解决你的问题,请参考以下文章

BZOJ4430: [Nwerc2015]Guessing Camels赌骆驼

bzoj 4428: [Nwerc2015]Debugging调试

BZOJ4428[Nwerc2015]Debugging调试 记忆化搜索+分块

BZOJ4429[Nwerc2015] Elementary Math小学数学 最大流

[bzoj4429] [Nwerc2015] Elementary Math小学数学

bzoj4428[Nwerc2015]Debugging调试 数论+记忆化搜索