HDU 1027 Ignatius and the Princess II(求第m个全排列)

Posted 若有恒,何必三更起五更眠;最无益,莫过一日曝十日寒。

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1027 Ignatius and the Princess II(求第m个全排列)相关的知识,希望对你有一定的参考价值。

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1027

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10388    Accepted Submission(s): 5978


Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it\'s easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It\'s easy, isn\'t is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub\'s demand. The input is terminated by the end of file.
 

 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub\'s demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

 

Sample Input
6 4 11 8
 

 

Sample Output
1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10
 

 

Author
Ignatius.L
 
分析:
题目意思:
1~n的全排列
求第m个(按照字典序排序)
复杂点的方法就是直接按照求全排列的方法
求出第m个就可以
但是我用的是另外一种方法
调用next_permutation函数:调用依次此函数就是把这个序列变成下一个序列
求到第m个输出就好
code:
 
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        int a[n];
        int k=1;
        for(int i=0;i<n;i++)
        {
            a[i]=i+1;
        }
        while(next_permutation(a,a+n))//调用依次此函数就是把这个序列变成下一个序列
        {
            k++;
            if(k==m)
                break;
        }
        printf("%d",a[0]);
        for(int i=1;i<n;i++)
        {
            printf(" %d",a[i]);
        }
        printf("\\n");
    }
    return 0;
}

 

以上是关于HDU 1027 Ignatius and the Princess II(求第m个全排列)的主要内容,如果未能解决你的问题,请参考以下文章

HDU_1027_Ignatius and the Princess II_全排列

HDU 1027 Ignatius and the Princess II(求第m个全排列)

HDU 1027 Ignatius and the Princess II[DFS/全排列函数next_permutation]

hdu 1028 Ignatius and the Princess III

hdu 1028 Ignatius and the Princess III

hdu1029 Ignatius and the Princess IV