HDU 2026 首字母变大写

Posted zlrrrr

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 2026 首字母变大写相关的知识,希望对你有一定的参考价值。

http://acm.hdu.edu.cn/showproblem.php?pid=2026

 

Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 
Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 
Output
请输出按照要求改写后的英文句子。
 
Sample Input
i like acm
i want to get an accepted
 
Sample Output
I Like Acm
I Want To Get An Accepted
 
代码:
#include <bits/stdc++.h>

using namespace std;

char s[111];

int main()
{
    while(gets(s))
    {
        int len = strlen(s);
        if(s[0]>=‘a‘&&s[0]<=‘z‘)
            s[0]=s[0]-32;
        for(int i=0; i<len; i++)
        {
            if(s[i]==‘ ‘)
                s[i+1]-=32;
        }
        for(int i=0; i<len; i++)
        {
            printf("%c",s[i]);
        }
        cout<<endl;
    }
    return 0;
}

  

以上是关于HDU 2026 首字母变大写的主要内容,如果未能解决你的问题,请参考以下文章

HDU2026 首字母变大写文本处理

HDU2026 首字母变大写文本处理

hdu 2026 首字母变大写

首字母变大写(hdu2026)

java 判断字符串首字母大写,非首字母小写代码

我看书JavaScript将每个单词首字母变大写