hdu 2026 首字母变大写

Posted wz-archer

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 2026 首字母变大写相关的知识,希望对你有一定的参考价值。

Problem Description

输入一个英文句子,将每个单词的第一个字母改成大写字母。

Input

输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。

Output

请输出按照要求改写后的英文句子。

Sample Input

i like acm
i want to get an accepted

Sample Output

I Like Acm
I Want To Get An Accepted
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=2e5+10;
const int mod=1e9+7;

char a[maxn];

int main(){
    while(gets(a)){
        int len=strlen(a);
        for(int i=1;i<len;i++){
            if(a[i]<=z&&a[i]>=a&&a[i-1]== ){
                a[i]-=a;
                a[i]+=A;
            }
        }
        if(a[0]<=z&&a[0]>=a){
            a[0]-=a;
            a[0]+=A;
        }
        puts(a);
    }
    return 0;
}

 

以上是关于hdu 2026 首字母变大写的主要内容,如果未能解决你的问题,请参考以下文章

HDU2026 首字母变大写文本处理

HDU2026 首字母变大写文本处理

hdu 2026 首字母变大写

首字母变大写(hdu2026)

java 判断字符串首字母大写,非首字母小写代码

我看书JavaScript将每个单词首字母变大写