1036

Posted tookkke

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1036相关的知识,希望对你有一定的参考价值。

Average is not Fast Enough!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5108    Accepted Submission(s): 2075


Problem Description A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race. 

You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it? 
So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is over.
 
Input The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and seconds, respectively. In the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.
 
Output For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been disqualified, output "-" instead. Adhere to the sample output for the exact format of presentation.
 
Sample Input
  
   2 12.5
  5 0:23:21 0:25:01
 42 0:23:32 -:--:--
  7 0:33:20 0:41:35
  
 
Sample Output
  
     5: 3:52 min/km
 42: -
  7: 6:00 min/km
  
  

  



    共n段路程,共d km长,把每一段的时间加起来,除以d四舍五入到个位就行了。

    最重要的就是读时间的问题,可以用一个字符串读,如果第0个字符是'-',就说明被淘汰,否则可以用sscanf把三个数从字符串里面读出来。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>

#define MAXN 80

using namespace std;

int n;
double d;
char kkke[MAXN];

int main()

	freopen("input.txt","r",stdin);
	freopen("output.txt","w",stdout);
	int a,b,b1,b2,b3;
	scanf("%d%lf",&n,&d);
	while(scanf("%d",&a)==1)
	
		b=0;
		for(int i=0;i<n;i++)
		
			scanf("%s",kkke);
			if(b!=-1)
			
				if(kkke[0]=='-')b=-1;
				else
				
					sscanf(kkke,"%d:%d:%d",&b1,&b2,&b3);
					b+=b1*3600+b2*60+b3;
				
			
		
		printf("%3d: ",a);
		if(b==-1)
		
			printf("-\\n");
		
		else
		
			b=(int)floor((double)b/d+0.5);
			printf("%d:%02d min/km\\n",b/60,b%60);
		
	
	return 0;





以上是关于1036的主要内容,如果未能解决你的问题,请参考以下文章

P1036选数

HDU 1036

1036:shepherd

1036. Boys vs Girls (25)

bzoj1036:

1036 Boys vs Girls (25 分)