POJ.2796feel good(单调栈)

Posted SSL_LKJ

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ.2796feel good(单调栈)相关的知识,希望对你有一定的参考价值。

feel good

Description

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people’s memories about some period of life.

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life.

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.
Input

The first line of the input contains n - the number of days of Bill’s life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, … an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.
Output

Print the greatest value of some period of Bill’s life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill’s life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

输入样例

6
3 1 6 4 52

输出样例

60
3 5

解题思路

单调栈

AC代码

#include<cstdio>
using namespace std;
int n;
long long s,sl=1,sr=1,tail,a[100005],l[100005],r[100005],f[100005],p[100005];
int main()

    scanf("%d",&n);
    for(int i=1;i<=n;i++)
     
    	scanf("%lld",&a[i]);
     	f[i]=f[i-1]+a[i];
        l[i]=r[i]=i;
     
    for(int i=1;i<=n;i++)
     
     	while(a[i]<=a[p[tail]]&&tail>=1)
     	
     	 	l[i]=l[p[tail]];
		    tail--;
     	
     	p[++tail]=i;
     
    tail=0;
    for(int i=n;i>=1;i--)
     
     	while(tail!=0&&a[i]<=a[p[tail]])
     	 
     	  	r[i]=r[p[tail]];
		   	tail--; 
     	 
     	p[++tail]=i;
     
    for(int i=1;i<=n;i++)
     if(a[i]*(f[r[i]]-f[l[i]-1])>s)
     
     	s=a[i]*(f[r[i]]-f[l[i]-1]);
        sl=l[i];
	    sr=r[i];	
     
    printf("%lld\\n%lld %lld",s,sl,sr); 

谢谢

以上是关于POJ.2796feel good(单调栈)的主要内容,如果未能解决你的问题,请参考以下文章

POJ2796Feel Good[单调栈]

POJ2796:Feel Good单调栈

POJ2796 Feel Good(单调栈)

poj2796 feel good 单调栈

poj2796 feel good 单调栈

POJ 2796 Feel Good(单调栈)