PAT 1096 Consecutive Factors[难]

Posted bluebluesea

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT 1096 Consecutive Factors[难]相关的知识,希望对你有一定的参考价值。

1096 Consecutive Factors (20 分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2?31??).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

 题目大意:给出数N,找出其最长连续因子,因子要从小选起。

//哇好难,越做越难,,,

#include <iostream>
#include <vector>
#include<math.h>
using namespace std;

int main()
{
   int n;
   cin>>n;
   int m=sqrt(n);
   int maxl=0,tp=0,bg=0;
   vector<int> vt;
   for(int i=2;i<=m;i++){
        int t=n;//这个i表示从哪个地方开始。
        if(n%i==0){
            tp++;
            t/=i;
            if(tp>maxl){
                maxl=tp;
                bg=i;//就是这个开始的时候。但是你得能整除才可以。哇这个好难。
            }
        }else{
            tp=0;
        }
   }
    cout<<maxl<<
;
    for(int i=bg;i<maxl+tp;i++){
        cout<<i;
        if(i!=maxl+tp-1)
            cout<<"*";
    }
   return 0;
}

 

//写不下去了,要考虑好多问题啊。 

 

以上是关于PAT 1096 Consecutive Factors[难]的主要内容,如果未能解决你的问题,请参考以下文章

PAT 1096 Consecutive Factors[难]

PAT 1096. Consecutive Factors

PAT 甲级 1096 Consecutive Factors

PAT甲级——1096 Consecutive Factors (数学题)

1096. Consecutive Factors (20)——PAT (Advanced Level) Practise

PAT Advanced 1096 Consecutive Factors (20分)