1036.old bill

Posted bernieloveslife

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1036.old bill相关的知识,希望对你有一定的参考价值。

题目描述:

    Among grandfather‘s papers a bill was found.
    72 turkeys $_679_
    The first and the last digits of the number that obviously represented the total price of those turkeys are replaced here by blanks (denoted _), for they are faded and are illegible. What are the two faded digits and what was the price of one turkey?
    We want to write a program that solves a general version of the above problem.
    N turkeys $_XYZ_
    The total number of turkeys, N, is between 1 and 99, including both. The total price originally consisted of five digits, but we can see only the three digits in the middle. We assume that the first digit is nonzero, that the price of one turkeys is an integer number of dollars, and that all the
turkeys cost the same price.
    Given N, X, Y, and Z, write a program that guesses the two faded digits and the original price. In case that there is more than one candidate for the original price, the output should be the most expensive one. That is, the program is to report the two faded digits and the maximum price per turkey for the turkeys.

输入:

    The first line of the input file contains an integer N (0<N<100), which represents the number of turkeys. In the following line, there are the three decimal digits X, Y, and Z., separated by a space, of the original price $_XYZ_.

输出:

    For each case, output the two faded digits and the maximum price per turkey for the turkeys.

样例输入:
72
6 7 9
5
2 3 7
78
0 0 5
样例输出:
3 2 511
9 5 18475
0
#include<iostream>
using namespace std; //用一个数字把i,j记下来!!! 

bool money(int n,int a,int b,int c,int d,int e)
{
    int m=e+d*10+c*100+b*1000+a*10000;
    if(m%n==0) return true;
    else return false;
}

int price(int n,int a,int b,int c,int d,int e){
    int m=e+d*10+c*100+b*1000+a*10000;
    int p=m/n;
    return p;
}

int main(){
    int n,x,y,z,i,j,a,b;
    while(cin>>n){
        int flag=0,flag1=0;
        cin>>x>>y>>z;
        for(i=9;i>=0;i--)
        {
            for(j=9;j>=0;j--)
            {
                if(money(n,i,x,y,z,j)==true){
                    a=i;
                    b=j;
                    flag=1;
                    flag1=1;break;
                }
                if(flag1==1) break;
            }
        }
         if(flag==1) cout<<a<<" "<<b<<" "<<price(n,a,x,y,z,b)<<endl;
          else cout<<"0"<<endl;
    }
    return 0;
}

 








以上是关于1036.old bill的主要内容,如果未能解决你的问题,请参考以下文章

错误代码: 1005 Can't create table 'hibernate.bill' (errno: 150)

Javascript函数/未定义错误 - 提示计算

分享《Python语言及其应用》+PDF+源码+Bill Lubanovic+丁嘉瑞

1016. Phone Bills (25)——PAT (Advanced Level) Practise

PAT (Advanced Level) 1016 Phone Bills

如何使用Play Billing Library手动续订订阅?