[USACO06NOV]Bad Hair Day S(栈)
Posted markun0
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[USACO06NOV]Bad Hair Day S(栈)相关的知识,希望对你有一定的参考价值。
题目大意:
按顺序给出n头牛的身高,每头牛可以看见它到后出现的牛中第一头身高高过(大于等于)它的牛之间的所有牛,求所有牛总共能看到的牛数
解题思路:
从后往前遍历查看每头牛能看到的牛数,每次进行的比较数量的太多,但我们可以用栈来存储关键信息以减少不必要的比较
代码如下:
#include <bits/stdc++.h>
#include<algorithm>
using namespace std;
#define ll long long
#define N 80005
int a[N];
//每头牛的身高和所能看到的别的牛的头发的数量
struct P
int x, num=0;
P(int x, int num) :x(x), num(num)
;
stack<P>ans;
ll sum = 0;
int main()
ios::sync_with_stdio(0);
cin.tie(0);
cout.tie(0);
int n,w; cin >> n;
for (int i = 1; i <= n; i++)
cin >> a[i];
for (int i = n; i; i--)
int num = 0;
while (!ans.empty() && a[i] > ans.top().x)
num += ans.top().num+1;
//去掉冗杂元素
ans.pop();
sum += num;
//存入该头牛的信息
ans.push(P(a[i],num));
cout << sum;
POJ 3250 Bad Hair Day
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 17727 | Accepted: 5981 |
Description
Some of Farmer John‘s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows‘ heads.
Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.
Consider this example:
=
= =
= - = Cows facing right -->
= = =
= - = = =
= = = = = =
1 2 3 4 5 6
Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow‘s hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow‘s hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!
Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.
Input
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
Output
Sample Input
6 10 3 7 4 12 2
Sample Output
5
Source
1 #include <iostream> 2 #include <algorithm> 3 #include <map> 4 #include <vector> 5 #include <functional> 6 #include <string> 7 #include <cstring> 8 #include <queue> 9 #include <stack> 10 #include <set> 11 #include <cmath> 12 #include <cstdio> 13 using namespace std; 14 #define IOS ios_base::sync_with_stdio(false) 15 typedef long long LL; 16 const int INF = 0x3f3f3f3f; 17 const double PI=4.0*atan(1.0); 18 19 const int maxn=80000; 20 LL ans; 21 int n,h; 22 int main() 23 { 24 while(scanf("%d",&n)!=EOF){ 25 stack<int> s; 26 ans=0; 27 for(int i=0;i<n;i++){ 28 scanf("%d",&h); 29 while(!s.empty()&&h>=s.top()) s.pop(); 30 ans+=s.size(); 31 s.push(h); 32 } 33 printf("%lld\n",ans); 34 } 35 }
以上是关于[USACO06NOV]Bad Hair Day S(栈)的主要内容,如果未能解决你的问题,请参考以下文章
洛谷P2866 [USACO06NOV]糟糕的一天Bad Hair Day
洛谷 P2866 [USACO06NOV]糟糕的一天Bad Hair Day
[BZOJ] 1660: [Usaco2006 Nov]Bad Hair Day 乱发节