1011

Posted tookkke

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1011相关的知识,希望对你有一定的参考价值。

Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15189    Accepted Submission(s): 4085


Problem Description You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
 
Input The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.
 
Output For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
 
Sample Input
  
   5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1
  
 
Sample Output
  
   50
7
  


    就是说n个房间构成一棵树,1号房间为根节点,每个房间有虫子和脑虫,一个士兵可以打20个虫子,然后有m个士兵,问最多能够捕获多少脑虫。

    树形dp,节点i的代价v[i]为(虫子数+19)/20,价值w[i]为脑虫数。

    dp[i][j]表示到节点i时用了j个士兵得到的最大价值,然后每一步有点像背包问题,确定走那些分支。

    一定要特判if(m==0)printf("0\\n");被这个坑了一个月,一度想放弃,最后看讨论才弄对。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

#define MAXN 110

using namespace std;

int n,m;
int kkke[MAXN];
int hehe[MAXN];
int dp[MAXN][MAXN];

struct the_edge
	int to;
	int next;
edge[MAXN*2];
int head[MAXN],top;

void add(int a,int b)

	edge[top].to=b;
	edge[top].next=head[a];
	head[a]=top++;


void init()

	top=0;
	for(int i=1;i<=n;i++)
	
	    scanf("%d%d",&kkke[i],&hehe[i]);
	    kkke[i]=(kkke[i]+19)/20;
	    head[i]=-1;
	
	int a,b;
	for(int i=1;i<n;i++)
	
		scanf("%d%d",&a,&b);
		add(a,b);
		add(b,a);
	


void work(int nown,int p)

	for(int i=0;i<=m;i++)dp[nown][i]=0;
	for(int k=head[nown];k!=-1;k=edge[k].next)
	
		if(edge[k].to==p)continue;
		work(edge[k].to,nown);
		for(int i=m;i;i--)
		
			for(int j=1;j<=i;j++)
			
				dp[nown][i]=max(dp[nown][i],dp[edge[k].to][j]+dp[nown][i-j]);
			
		
	
	for(int i=m;i>=kkke[nown];i--)dp[nown][i]=dp[nown][i-kkke[nown]]+hehe[nown];
	for(int i=0;i<kkke[nown];i++)dp[nown][i]=0;


int main()

	freopen("input.txt","r",stdin);
	freopen("output.txt","w",stdout);
	while(scanf("%d%d",&n,&m),(n!=-1))
	
		init();
		if(m)
		
		    work(1,-1);
		    printf("%d\\n",dp[1][m]);
	    
	    else printf("0\\n");
	 
	return 0;







以上是关于1011的主要内容,如果未能解决你的问题,请参考以下文章

Starship Troopers(HDU 1011 树形DP)

HDOJ-ACM1011(JAVA)

Binary Search474B

今天吃苹果,发现里面有一只小小的虫子🐛、怎么办,是否寄生虫

我吃苹果时吃到一只绿色的小虫子,没事吧?

虫子和HTML代码