UVA10417 Gift Exchanging概率
Posted 海岛Blog
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA10417 Gift Exchanging概率相关的知识,希望对你有一定的参考价值。
You’re attending a Xmas party, every one there (excepty you, I don’t know why…) has brought a beautiful little gift in a box. After all the gifts are collected and laid on the table, every one can choose one to take home. You are the first one to choose, so there is a big chance for you to get the gift that is brought by your best friend 😃
Unfortunately, you cannot see inside the gift box, but luckily, there are only 5 possible kinds of boxes allowed in the party. We use A, B, C, D, E to represent these five kinds. You know well about all the guests there. i.e you know the probability that each person brings each kind of box. Which box should you take home, and what is the probability that you get the one you want?
Input
The first line of the input is a single integer t (1 ≤ t ≤ 10), indicating the number of test cases. Each case begins with a line containing a single integer n (1 ≤ n ≤ 12), indicating the number of guests. The second line of the case contains 5 integers indicating the number of gifts of each kind. The sum of these 5 numbers always equals to n. The following n lines each contain 5 non-negative floating numbers (with one digit after decimal point) indicating the probabilities for him to take box A, B, C, D, E. The sum of 5 numbers always equals to 1.0. The first guest is your best friend.
Output
For each test case, print a single character indicating the box you should choose, then a single space, then the probability to 3 decimal places. If there are more than one best choices, print the smallest box number.
Sample Input
2
2
1 0 0 1 0
0.5 0.0 0.0 0.5 0.0
0.4 0.0 0.5 0.1 0.0
8
1 3 2 1 1
0.1 0.2 0.3 0.2 0.2
0.0 0.8 0.2 0.0 0.0
0.3 0.0 0.1 0.6 0.0
0.0 0.9 0.1 0.0 0.0
0.2 0.2 0.0 0.3 0.3
0.2 0.1 0.6 0.1 0.0
0.7 0.2 0.1 0.0 0.0
0.1 0.0 0.0 0.2 0.7
Sample Output
4 0.800
3 0.296
问题链接:UVA10417 Gift Exchanging
问题简述:(略)
问题分析:概率计算问题,不解释。解题代码来自仙客传奇团队。
程序说明:(略)
参考链接:(略)
题记:(略)
AC的C++语言程序如下:
/* UVA10417 Gift Exchanging */
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 5;
const int M=15;
const double EPS = 1e-9;
double p[M][N], res[N];
int n, t, cnt[N];
double dfs(int cur, double prob)
if (cur == n) return prob;
double ans = 0;
for (int i = 0; i < N; i++)
if(cnt[i] && p[cur][i] > EPS)
cnt[i]--;
double tmp = dfs(cur + 1, prob * p[cur][i]);
ans += tmp;
if (cur == 0) res[i] += tmp;
cnt[i]++;
return ans;
int main()
scanf("%d", &t);
while (t--)
scanf("%d", &n);
for (int i = 0; i < N; i++)
scanf("%d", &cnt[i]);
for (int i = 0; i < n; i++)
for (int j = 0; j < N; j++)
scanf("%lf", &p[i][j]);
memset(res, 0, sizeof(res));
double all = dfs(0, 1);
int id=0;
double ans=0;
for (int i = 0; i < N; i++)
double tmp = res[i] / cnt[i]; //从该包装中所有礼物恰好能选到bf送的礼物概率为1/cnt[i]
if (tmp - ans > EPS)
id = i, ans = tmp;
printf("%d %.3f\\n", id + 1, ans / all);
return 0;
以上是关于UVA10417 Gift Exchanging概率的主要内容,如果未能解决你的问题,请参考以下文章
UVA10120 ZOJ1229 Gift?!DFS+BFS
UVA 11346 Probability (几何概型, 积分)
Exchanging Gifts--2019CCPC哈尔滨 E题
The 2019 China Collegiate Programming Contest Harbin Site E - Exchanging Gifts 拓扑图+离散化