HiHocoder 1288 FontSize

Posted 计算机科学家的世界

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HiHocoder 1288 FontSize相关的知识,希望对你有一定的参考价值。

#1288 : Font Size

时间限制: 10000ms 单点时限: 1000ms 内存限制: 256MB

描述

Steven loves reading book on his phone. The book he reads now consists of N paragraphs and the i-th paragraph contains ai characters.

Steven wants to make the characters easier to read, so he decides to increase the font size of characters. But the size of Steven's phone screen is limited. Its width is W and height is H. As a result, if the font size of characters is S then it can only show ⌊W / S⌋ characters in a line and ⌊H / S⌋ lines in a page. (⌊x⌋ is the largest integer no more than x)  

So here's the question, if Steven wants to control the number of pages no more than P, what's the maximum font size he can set? Note that paragraphs must start in a new line and there is no empty line between paragraphs.

输入

Input may contain multiple test cases.

The first line is an integer TASKS, representing the number of test cases.

For each test case, the first line contains four integers N, P, W and H, as described above.

The second line contains N integers a1, a2, ... aN, indicating the number of characters in each paragraph.


For all test cases,

1 <= N <= 103,

1 <= W, H, ai <= 103,

1 <= P <= 106,

There is always a way to control the number of pages no more than P.

输出

For each testcase, output a line with an integer Ans, indicating the maximum font size Steven can set.

样例输入
2
1 10 4 3
10
2 10 4 3
10 10
样例输出
3

2


算法思想:

二分搜索,对于一个字体大小S,可以判断S是否满足条件


代码如下:

#include <iostream>
#include <algorithm>
using namespace std;

int N, P, W, H;
int Paragraph[10000];

void HandleCase();

int main() 
	int iCase;
	cin >> iCase;
	while (iCase--)
		HandleCase();
	



bool OK(int S);

void HandleCase() 
	cin >> N >> P >> W >> H;
	for (int i = 0; i < N; ++i) 
		cin >> Paragraph[i];
	
	int l = 1, r = min(W, H), m;
	while (l < r) 
		m = (l + r) >> 1;
		if (OK(m)) 
			l = m + 1;
		 else 
			r = m - 1;
		
	

	while (!OK(l)) --l;

	cout << l  << endl;


bool OK(int S) 
	int iEachLine = W / S;
	int iLine	  = H / S;
	int TotalLine = 0;
	if(iEachLine <= 0 || iLine <= 0)
		return false;
	for (int i = 0; i < N; ++i) 
		if (iEachLine == 1) 
			TotalLine += Paragraph[i];
		else
			TotalLine += (Paragraph[i] + iEachLine - 1) / iEachLine ;
		
	
	return (TotalLine + iLine - 1) / iLine <= P;


结果:

1288 Font Size AC G++ 6ms 0MB 5分钟前 查看

以上是关于HiHocoder 1288 FontSize的主要内容,如果未能解决你的问题,请参考以下文章

hihoCoder #1288 : Font Size

hihoCoder 1233 : Boxes(盒子)

hihocoder-1497-Queen Attack

hihocoder-1498-Diligent Robots

hihocoder#1239 Fibonacci

hihocoder 1391 树状数组