hihocoder-1497-Queen Attack

Posted zhang-yd

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hihocoder-1497-Queen Attack相关的知识,希望对你有一定的参考价值。

hihocoder-1497-Queen Attack

 

#1497 : Queen Attack

时间限制:10000ms
单点时限:1000ms
内存限制:256MB

描述

There are N queens in an infinite chessboard. We say two queens may attack each other if they are in the same vertical line, horizontal line or diagonal line even if there are other queens sitting between them.

Now given the positions of the queens, find out how many pairs may attack each other?

输入

The first line contains an integer N.

Then N lines follow. Each line contains 2 integers Ri and Ci indicating there is a queen in the Ri-th row and Ci-th column.  

No two queens share the same position.  

For 80% of the data, 1 <= N <= 1000

For 100% of the data, 1 <= N <= 100000, 0 <= Ri, Ci <= 1000000000

输出

One integer, the number of pairs may attack each other.

样例输入
5  
1 1  
2 2  
3 3   
1 3
3 1
样例输出
10

 

题解:

  使用unordered_map, 记录之前添加过的position,因为不可能同时两个position重叠,两两attack的position必定只存在着一种相交方式。

 

 

 

#include <cstdio> 
#include <cstdlib> 

#include <iostream>
#include <unordered_map> 
using namespace std;  

int main()

    int n, x, y;
    long long ans = 0; 
    scanf("%d", &n); 
    unordered_map<int, int> hor; 
    unordered_map<int, int> vet; 
    unordered_map<int, int> dx; 
    unordered_map<int, int> vdx; 
    for(int i=0; i<n; ++i)
    
        scanf("%d %d", &x, &y); 
        if(hor.find(x) != hor.end())
        
            ans += hor[x]; 
            hor[x] += 1; 
        else
            hor[x] = 1; 
        

        if(vet.find(y) != vet.end())
        
            ans += vet[y]; 
            vet[y] += 1; 
        else
            vet[y] = 1; 
        

        if(dx.find(x-y) != dx.end())
        
            ans += dx[x-y]; 
            dx[x-y] += 1; 
        else
            dx[x-y] = 1; 
        

        if(vdx.find(x+y) != vdx.end())
        
            ans += vdx[x+y]; 
            vdx[x+y] += 1; 
        else
            vdx[x+y] = 1; 
        

    
    printf("%lld\n", ans );

  

 

以上是关于hihocoder-1497-Queen Attack的主要内容,如果未能解决你的问题,请参考以下文章

岩体结构面组蚁群ATTA聚类算法

DDoS

格式与布局

图片在节点中附加主题图片

碰撞自动攻击

iOS 读取图片的各种方法