2021.8.11提高B组模拟3T2 + P2323 [HNOI2006] 公路修建问题(并查集)

Posted SSL_LKJ

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了2021.8.11提高B组模拟3T2 + P2323 [HNOI2006] 公路修建问题(并查集)相关的知识,希望对你有一定的参考价值。

公路修建问题

洛谷题目传送门


注:以下题目是集训上的

输入样例

1.

4 2 5
1 2 6 5
1 3 3 1
2 3 9 4
2 4 6 1
3 4 4 2

2.

4 1 5
1 2 6 5
1 3 3 1
2 3 9 4
2 4 6 1
3 4 4 3

输出样例

1.

4

2.

3

解题思路

就是先排序一遍一级公路(小到大)
选择k条短的一级公路来建(当然不能构成环
排序一遍二级公路(小到大)
选择短的二级公路来建(同样也不能构成环
使选择的公路个数为 n-1,并且 n 个城市都必须连通

这里,我们判断 不能构成环 + 必须连通 的东西是并查集
判断它们是否所属同一个集合(因为公路都是无向的),如果不是则建公路

记得实时更新答案


洛谷的

大致思路同上
只是需要多开一个结构体内的num,用来存储初始位置就 AC

注:洛谷上的m要减一

AC代码

集训的

#include<algorithm>
#include<cstdio>
using namespace std;
int n,k,m,o,ans,fa[10005];
struct node1

	int x,y,c1,c2;
b[20005];
bool cmp1(node1 x,node1 y)

	return x.c1<y.c1;

bool cmp2(node1 x,node1 y)

	return x.c2<y.c2;

int getfather(int x)

	if(fa[x]==x)return x;
	return fa[x]=getfather(fa[x]);

int main()

	scanf("%d%d%d",&n,&k,&m);
	for(int i=1;i<=m;i++)
		scanf("%d%d%d%d",&b[i].x,&b[i].y,&b[i].c1,&b[i].c2);
	sort(b+1,b+m+1,cmp1);//排序一级公路
	for(int i=1;i<=n;i++)fa[i]=i; //初值
	for(int i=1;i<=m;i++)
	
		if(o==k)break;
		int x=getfather(b[i].x),y=getfather(b[i].y);
		if(x!=y)//判断所属集合
		
			o++;//连一级边的个数
			fa[x]=fa[y];//合并
			ans=max(ans,b[i].c1);//实时更新
		
	
	sort(b+1,b+m+1,cmp2);//排序二级公路
	for(int i=1;i<=m;i++)//大致同上一个for
	
		int x=getfather(b[i].x),y=getfather(b[i].y);
		if(x!=y)
		
			fa[x]=fa[y];
			ans=max(ans,b[i].c2);
		
	
	printf("%d",ans);
	return 0;


洛谷P2323的

前面的解析上一个程序有,就不过多解析了

#include<algorithm>
#include<cstdio>
using namespace std;
int n,k,m,o,tot,ans,fa[10005];
struct node

	int num,ji;
a[10005];
struct node1

	int x,y,c1,c2,num;
b[20005];
bool cmp1(node1 x,node1 y)

	return x.c1<y.c1;

bool cmp2(node1 x,node1 y)

	return x.c2<y.c2;

bool cmp3(node x,node y)

	return x.num<y.num;

int getfather(int x)

	if(fa[x]==x)return x;
	return fa[x]=getfather(fa[x]);

int main()

	scanf("%d%d%d",&n,&k,&m);
	for(int i=1;i<m;i++)
	
		scanf("%d%d%d%d",&b[i].x,&b[i].y,&b[i].c1,&b[i].c2);
		b[i].num=i;
	
	sort(b+1,b+m,cmp1);
	for(int i=1;i<=n;i++)fa[i]=i; 
	for(int i=1;i<m;i++)
	
		if(o==k)break;
		int x=getfather(b[i].x),y=getfather(b[i].y);
		if(x!=y)
		
			o++;
			fa[x]=fa[y];
			a[++tot]=(node)b[i].num,1;//存储答案
			ans=max(ans,b[i].c1);
		
	
	sort(b+1,b+m,cmp2);
	for(int i=1;i<m;i++)
	
		int x=getfather(b[i].x),y=getfather(b[i].y);
		if(x!=y)
		
			fa[x]=fa[y];
			a[++tot]=(node)b[i].num,2;//存储答案
			ans=max(ans,b[i].c2);
		
	
	sort(a+1,a+tot+1,cmp3);//答案要排序
	printf("%d\\n",ans);
	for(int i=1;i<=tot;i++)
		printf("%d %d\\n",a[i].num,a[i].ji);
	return 0;


谢谢

以上是关于2021.8.11提高B组模拟3T2 + P2323 [HNOI2006] 公路修建问题(并查集)的主要内容,如果未能解决你的问题,请参考以下文章

2021.7.14提高B组模拟3T2 积木 (dp)

2021.8.11提高B组模拟3T1 积木(乱糊暴搜)(正解:状压dp)

2021.8.11提高B组模拟3T1 积木(乱糊暴搜)(正解:状压dp)

2017.12.09NOIP提高组模拟赛A组

2017.07.16【NOIP提高组】模拟赛B组 卫星照片 题解

2017.07.14NOIP提高组模拟赛B组