hdu1397(Goldbach`s Conjecture )

Posted ACRykl

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu1397(Goldbach`s Conjecture )相关的知识,希望对你有一定的参考价值。

Goldbach‘s Conjecture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7550    Accepted Submission(s): 2877


Problem Description
Goldbach‘s Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.
 
Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
 
Output
Each output line should contain an integer number. No other characters should appear in the output.
 
Sample Input
6 10 12 0
Sample Output
1 2 1
 
分析:用筛法求素数并用数组s记录下来就好了。
技术分享图片
#include<cstdio>
bool a[10000010];
int s[1000000];
int cnt=0;
void prime()
{
    for(int i=4;i<10000001;i+=2) a[i]=1;
    s[cnt++]=2;
    for(int i=3;i<10000001;i++)
    {
        if(!a[i])
        {
            s[cnt++]=i;
            for(int j=i+i;j<10000001;j+=i)
            a[j]=1;
        }
    } 
}

int main()
{
    int n;
    prime();
    while(scanf("%d",&n)&&n)
    {
        int N=n/2,ans=0;
        int i=0;
        while(s[i]<=N)
        {
            if(!a[n-s[i]]) ans++;
            i++;
        }
        printf("%d\n",ans);
    }
    return 0;
}
View Code

 

 







以上是关于hdu1397(Goldbach`s Conjecture )的主要内容,如果未能解决你的问题,请参考以下文章

问题 C: Goldbach's Conjecture

F - Goldbach`s Conjecture kuangbin 基础数论

一本通1622Goldbach’s Conjecture

F - Goldbach`s Conjecture

IEEEXtreme 10.0 - Goldbach's Second Conjecture

LightOJ1259 Goldbach`s Conjecture 线性筛